summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormzz20172020-03-27 07:42:52 +0000
committermzz20172020-03-27 07:42:52 +0000
commit9de88531f73c124a84859d9c4217c335ba114f38 (patch)
treee8f92a5ccf4f5c8a088650ecd5ef4c138a075132
downloadaur-9de88531f73c124a84859d9c4217c335ba114f38.tar.gz
release v0.6.8.2
-rwxr-xr-x.INSTALL48
-rw-r--r--.SRCINFO57
-rw-r--r--PKGBUILD88
-rw-r--r--v2raya.desktop8
-rwxr-xr-xv2raya.pngbin0 -> 80828 bytes
-rw-r--r--v2raya.service15
6 files changed, 216 insertions, 0 deletions
diff --git a/.INSTALL b/.INSTALL
new file mode 100755
index 000000000000..a9546c09ed5a
--- /dev/null
+++ b/.INSTALL
@@ -0,0 +1,48 @@
+#!/bin/sh
+
+post_install() {
+ systemctl daemon-reload
+ systemctl enable v2raya
+ systemctl start v2raya
+
+ ECHOLEN=$(echo -e|awk '{print length($0)}')
+ if [ ${ECHOLEN} = '0' ]
+ then
+ ECHO='echo -e'
+ else
+ ECHO='echo'
+ fi;
+ $ECHO "\033[36m**************************************\033[0m"
+ $ECHO "\033[36m* Congratulations! *\033[0m"
+ $ECHO "\033[36m* HTTPS demo: https://v2raya.mzz.pub *\033[0m"
+ $ECHO "\033[36m* HTTP demo: http://v.mzz.pub *\033[0m"
+ $ECHO "\033[36m**************************************\033[0m"
+}
+
+post_upgrade() {
+ systemctl daemon-reload
+ systemctl restart v2raya
+
+ ECHOLEN=$(echo -e|awk '{print length($0)}')
+ if [ ${ECHOLEN} = '0' ]
+ then
+ ECHO='echo -e'
+ else
+ ECHO='echo'
+ fi;
+ $ECHO "\033[36m**************************************\033[0m"
+ $ECHO "\033[36m* Congratulations! *\033[0m"
+ $ECHO "\033[36m* HTTPS demo: https://v2raya.mzz.pub *\033[0m"
+ $ECHO "\033[36m* HTTP demo: http://v.mzz.pub *\033[0m"
+ $ECHO "\033[36m**************************************\033[0m"
+}
+
+pre_remove() {
+ systemctl disable v2raya
+ systemctl stop v2raya
+ systemctl stop v2ray
+}
+
+post_remove() {
+ systemctl daemon-reload
+}
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..30cfc18c0e7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,57 @@
+pkgbase = v2raya-bin
+ pkgdesc = V2Ray Linux client with web GUI, compatible with SS and SSR, supporting transparent proxy
+ pkgver = 0.6.8.2
+ pkgrel = 1
+ url = https://github.com/mzz2017/V2RayA
+ install = .INSTALL
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = armv6h
+ arch = aarch64
+ license = GPL
+ depends = glibc
+ depends = v2ray
+ source_i686 = v2raya::https://apt.v2raya.mzz.pub/pool/main/v/v2raya/v2raya_linux_386_v0.6.8.2
+ source_i686 = v2raya.service
+ source_i686 = v2raya.png
+ source_i686 = v2raya.desktop
+ sha1sums_i686 =
+ sha1sums_i686 =
+ sha1sums_i686 =
+ sha1sums_i686 =
+ source_x86_64 = v2raya::https://apt.v2raya.mzz.pub/pool/main/v/v2raya/v2raya_linux_amd64_v0.6.8.2
+ source_x86_64 = v2raya.service
+ source_x86_64 = v2raya.png
+ source_x86_64 = v2raya.desktop
+ sha1sums_x86_64 =
+ sha1sums_x86_64 =
+ sha1sums_x86_64 =
+ sha1sums_x86_64 =
+ source_armv7h = v2raya::https://apt.v2raya.mzz.pub/pool/main/v/v2raya/v2raya_linux_arm_v0.6.8.2
+ source_armv7h = v2raya.service
+ source_armv7h = v2raya.png
+ source_armv7h = v2raya.desktop
+ sha1sums_armv7h =
+ sha1sums_armv7h =
+ sha1sums_armv7h =
+ sha1sums_armv7h =
+ source_armv6h = v2raya::https://apt.v2raya.mzz.pub/pool/main/v/v2raya/v2raya_linux_arm_v0.6.8.2
+ source_armv6h = v2raya.service
+ source_armv6h = v2raya.png
+ source_armv6h = v2raya.desktop
+ sha1sums_armv6h =
+ sha1sums_armv6h =
+ sha1sums_armv6h =
+ sha1sums_armv6h =
+ source_aarch64 = v2raya::https://apt.v2raya.mzz.pub/pool/main/v/v2raya/v2raya_linux_arm64_v0.6.8.2
+ source_aarch64 = v2raya.service
+ source_aarch64 = v2raya.png
+ source_aarch64 = v2raya.desktop
+ sha1sums_aarch64 =
+ sha1sums_aarch64 =
+ sha1sums_aarch64 =
+ sha1sums_aarch64 =
+
+pkgname = v2raya-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eef0a023b054
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,88 @@
+# Maintainer: mzz2017 <m@mzz.pub>
+
+pkgname=v2raya-bin
+_pkgname=v2raya
+pkgver=0.6.8.2
+pkgrel=1
+install=.INSTALL
+pkgdesc="V2Ray Linux client with web GUI, compatible with SS and SSR, supporting transparent proxy"
+arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
+url="https://github.com/mzz2017/V2RayA"
+license=('GPL')
+depends=('glibc' 'v2ray')
+
+sha_service=
+sha_png=
+sha_desktop=
+
+source_i686=(
+ "v2raya::https://apt.v2raya.mzz.pub/pool/main/v/v2raya/v2raya_linux_386_v${pkgver}"
+ "v2raya.service"
+ "v2raya.png"
+ "v2raya.desktop"
+)
+source_x86_64=(
+ "v2raya::https://apt.v2raya.mzz.pub/pool/main/v/v2raya/v2raya_linux_amd64_v${pkgver}"
+ "v2raya.service"
+ "v2raya.png"
+ "v2raya.desktop"
+)
+source_aarch64=(
+ "v2raya::https://apt.v2raya.mzz.pub/pool/main/v/v2raya/v2raya_linux_arm64_v${pkgver}"
+ "v2raya.service"
+ "v2raya.png"
+ "v2raya.desktop"
+)
+source_armv6h=(
+ "v2raya::https://apt.v2raya.mzz.pub/pool/main/v/v2raya/v2raya_linux_arm_v${pkgver}"
+ "v2raya.service"
+ "v2raya.png"
+ "v2raya.desktop"
+)
+source_armv7h=(
+ "v2raya::https://apt.v2raya.mzz.pub/pool/main/v/v2raya/v2raya_linux_arm_v${pkgver}"
+ "v2raya.service"
+ "v2raya.png"
+ "v2raya.desktop"
+)
+
+sha1sums_i686=(
+ ''
+ "$sha_service"
+ "$sha_png"
+ "$sha_desktop"
+)
+sha1sums_x86_64=(
+ ''
+ "$sha_service"
+ "$sha_png"
+ "$sha_desktop"
+)
+sha1sums_aarch64=(
+ ''
+ "$sha_service"
+ "$sha_png"
+ "$sha_desktop"
+)
+sha1sums_armv6h=(
+ ''
+ "$sha_service"
+ "$sha_png"
+ "$sha_desktop"
+)
+sha1sums_armv7h=(
+ ''
+ "$sha_service"
+ "$sha_png"
+ "$sha_desktop"
+)
+
+package() {
+ cd "$srcdir"
+
+ install -Dm644 "v2raya.service" "$pkgdir/usr/lib/systemd/system/v2raya.service"
+ install -Dm755 "v2raya" -t "$pkgdir/usr/bin/"
+
+ install -Dm644 "v2raya.png" "$pkgdir/usr/share/icons/v2raya.png"
+ install -Dm755 "v2raya.desktop" -t "$pkgdir/usr/share/applications/"
+}
diff --git a/v2raya.desktop b/v2raya.desktop
new file mode 100644
index 000000000000..6c60717cfff5
--- /dev/null
+++ b/v2raya.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Version=1.0
+Terminal=false
+Type=Application
+Name=V2RayA
+Keywords=Internet;VPN;Proxy;v2ray;v2raya
+Exec=python -m webbrowser "https://v2raya.mzz.pub"
+Icon=/usr/share/icons/v2raya.png \ No newline at end of file
diff --git a/v2raya.png b/v2raya.png
new file mode 100755
index 000000000000..202a36308129
--- /dev/null
+++ b/v2raya.png
Binary files differ
diff --git a/v2raya.service b/v2raya.service
new file mode 100644
index 000000000000..ffa52d62ae56
--- /dev/null
+++ b/v2raya.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=V2RayA Service
+Documentation=https://github.com/mzz2017/V2RayA/blob/master/README.md
+After=network.target
+Wants=network.target
+
+[Service]
+Type=simple
+CapabilityBoundingSet=CAP_NET_ADMIN CAP_NET_RAW CAP_NET_BIND_SERVICE
+Environment=V2RAYA_CONFIG=/etc/v2ray/v2raya.json
+ExecStart=/usr/bin/v2raya
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target \ No newline at end of file