summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2018-09-03 23:37:55 -0400
committerTony Lambiris2018-09-03 23:37:55 -0400
commit9e1ef3578b04eea0358d0c9a868d14cf4cd5e2ba (patch)
treeb99ddd37bbc6ecbdc671288d8e49b9b7bed4b2ae
parent581a858ed292e0e2de2eb8e47287685505ebda80 (diff)
downloadaur-9e1ef3578b04eea0358d0c9a868d14cf4cd5e2ba.tar.gz
Version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--arch-linux.patch10
3 files changed, 9 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ffd45bc60c3..eba4d2087445 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = osquery-git
pkgdesc = SQL powered operating system instrumentation, monitoring, and analytics.
- pkgver = 3.3.0.r72.g1103d2cf2
- pkgrel = 2
+ pkgver = 3.3.0.r117.gc301e361c
+ pkgrel = 1
url = https://osquery.io
arch = i686
arch = x86_64
@@ -56,14 +56,14 @@ pkgbase = osquery-git
options = !strip
options = !ccache
backup = etc/osquery/osquery.conf
- source = osquery-git::git+https://github.com/facebook/osquery#commit=1103d2cf248a04d84d93394177b197c5c579f940
+ source = osquery-git::git+https://github.com/facebook/osquery#commit=c301e361ca3ffe4f718da220d0374890f67bf170
source = osqueryd.conf.d
source = osqueryd.service
source = arch-linux.patch
sha256sums = SKIP
sha256sums = ee15a171f114f47a326d236a7d03a07cc3e711016e9a5039638e6137f63e87ec
sha256sums = 0c28be3fb234325c3279aa3c02a5b0636db833c06f89ec551b77addb86507ce4
- sha256sums = eb7483518e0ed6bd60445209e5aad8a69585f1d1d9f9b07bce529af8f702ce86
+ sha256sums = e4b5fc12f116327482f93ee4cc2132c460ed6f0018fe228dac8d06c5da4f1a98
pkgname = osquery-git
diff --git a/PKGBUILD b/PKGBUILD
index 43f510c8e41a..e09a694eb0e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=osquery-git
-pkgver=3.3.0.r72.g1103d2cf2
-pkgrel=2
+pkgver=3.3.0.r117.gc301e361c
+pkgrel=1
pkgdesc="SQL powered operating system instrumentation, monitoring, and analytics."
arch=('i686' 'x86_64')
url="https://osquery.io"
@@ -20,7 +20,7 @@ makedepends=('asio' 'audit' 'aws-sdk-cpp-git' 'git' 'clang' 'benchmark'
conflicts=()
backup=('etc/osquery/osquery.conf')
options=(!strip !ccache)
-_gitcommit='1103d2cf248a04d84d93394177b197c5c579f940'
+_gitcommit='c301e361ca3ffe4f718da220d0374890f67bf170'
#source=("${pkgname}::git+https://github.com/facebook/osquery"
source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit}"
"osqueryd.conf.d"
@@ -29,9 +29,9 @@ source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit
sha256sums=('SKIP'
'ee15a171f114f47a326d236a7d03a07cc3e711016e9a5039638e6137f63e87ec'
'0c28be3fb234325c3279aa3c02a5b0636db833c06f89ec551b77addb86507ce4'
- 'eb7483518e0ed6bd60445209e5aad8a69585f1d1d9f9b07bce529af8f702ce86')
+ 'e4b5fc12f116327482f93ee4cc2132c460ed6f0018fe228dac8d06c5da4f1a98')
-##pkgver() {
+#pkgver() {
# cd ${pkgname}
#
# git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
diff --git a/arch-linux.patch b/arch-linux.patch
index f18cd01b1410..67288b74166a 100644
--- a/arch-linux.patch
+++ b/arch-linux.patch
@@ -57,16 +57,6 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
index c7b6b23b9..57b292ee7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -176,9 +176,6 @@ if(NOT WIN32)
- endif()
-
- if(POSIX)
-- add_compile_options(
-- -Werror
-- )
- if(CLANG)
- add_compile_options(
- -Qunused-arguments
@@ -330,7 +327,6 @@ if (POSIX)
# To be safe, only include them when building 'release' outputs.
add_compile_options(