summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Santini2024-02-25 19:07:42 +0100
committerGiovanni Santini2024-02-25 19:07:42 +0100
commit9e420ff372a20f67b8707055de0ba179c1388de5 (patch)
treec7f9a822e7967eba50b6a0d0d17419328cc31f64
parent0723c7756b54f79e1b705f77cadffe1fdf4021e2 (diff)
downloadaur-9e420ff372a20f67b8707055de0ba179c1388de5.tar.gz
upgpkg: popcorntime 0.5.0-1
- Version bump. - Change checksums to SHA512. - Add new build patch. - Avoid using old patch, since the new gulpfile.js is okay.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
-rw-r--r--yarn_lock-fixes.patch22
3 files changed, 43 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4cd7c2f0c0a6..26e9e4c880d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = popcorntime
pkgdesc = Stream movies from torrents. Skip the downloads. Launch, click, watch.
- pkgver = 0.4.9
- pkgrel = 2
- url = https://popcorntime.app/
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://popcorn-time.site/
arch = i686
arch = x86_64
license = GPL3
@@ -15,11 +15,11 @@ pkgbase = popcorntime
depends = ttf-font
optdepends = net-tools: vpn.ht client
options = !strip
- source = popcorn-desktop::git+https://github.com/popcorn-official/popcorn-desktop/#tag=v0.4.9
+ source = popcorn-desktop::git+https://github.com/popcorn-official/popcorn-desktop/#tag=v0.5.0
source = popcorntime.desktop
- source = gulp-fixes.patch
- sha256sums = SKIP
- sha256sums = 4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334
- sha256sums = 99c485d7b00ae1f4820e43149d6c93aff7c9b1f40d407beef369bc757688144a
+ source = yarn_lock-fixes.patch
+ sha512sums = SKIP
+ sha512sums = 7e6538a7b39465439a62cb089510b6d85a65ad4bfa74d21b692363d1176ee94165ab7b5fef5f3470bf821cfc9f3b3a23763b8e3d8530420d7fa97c66083c3adb
+ sha512sums = 1cb54fbc2690f4a473e50e786b12f5fcfffffb805cfd421e996bc0b278c13fd1252ab63cde576078eb1d7df060b5763a308a0dec9ffba8a0b568f78a6a326f8b
pkgname = popcorntime
diff --git a/PKGBUILD b/PKGBUILD
index aff5d2b3e018..cebaa4f8682f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,11 +8,11 @@
# Contributor: Ricardo Band <me [at] xengi [dot] de>
pkgname=popcorntime
-pkgver=0.4.9
-pkgrel=2
+pkgver=0.5.0
+pkgrel=1
pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch."
arch=(i686 x86_64)
-url="https://popcorntime.app/"
+url="https://popcorn-time.site/"
license=(GPL3)
depends=(gtk3 libxss nss ttf-font)
makedepends=(git npm yarn)
@@ -40,18 +40,23 @@ _bpath="${_srcdir}/build/Popcorn-Time/${_platform}"
source=(
"${_pkgname}::git+https://github.com/popcorn-official/${_pkgname}/#${_commit_hash}"
"popcorntime.desktop"
- "gulp-fixes.patch"
+ "yarn_lock-fixes.patch"
)
-sha256sums=('SKIP'
- '4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334'
- '99c485d7b00ae1f4820e43149d6c93aff7c9b1f40d407beef369bc757688144a')
+sha512sums=('SKIP'
+ '7e6538a7b39465439a62cb089510b6d85a65ad4bfa74d21b692363d1176ee94165ab7b5fef5f3470bf821cfc9f3b3a23763b8e3d8530420d7fa97c66083c3adb'
+ '1cb54fbc2690f4a473e50e786b12f5fcfffffb805cfd421e996bc0b278c13fd1252ab63cde576078eb1d7df060b5763a308a0dec9ffba8a0b568f78a6a326f8b')
# Building the package
prepare() {
cd "${srcdir}/${_srcdir}"
+ # echo "--> Apply Gulpfile fixes ..."
+ # git apply "$srcdir/gulp-fixes.patch"
+
+ # Some dependencies in the yarn.lock file use "git+ssh", which is unavailable.
+ # Use "git+https" instead.
echo "--> Apply Gulpfile fixes ..."
- git apply "$srcdir/gulp-fixes.patch"
+ git apply "$srcdir/yarn_lock-fixes.patch"
# Thanks to Eschwartz for the tip! yarn edition
export YARN_CACHE_FOLDER="$srcdir/npm_cache"
diff --git a/yarn_lock-fixes.patch b/yarn_lock-fixes.patch
new file mode 100644
index 000000000000..1e0353c8aa1a
--- /dev/null
+++ b/yarn_lock-fixes.patch
@@ -0,0 +1,22 @@
+diff --git a/yarn.lock b/yarn.lock
+index 9764d06ef..d7e51c545 100644
+--- a/yarn.lock
++++ b/yarn.lock
+@@ -7227,7 +7227,7 @@ teex@^1.0.1:
+
+ "temp@github:adam-lynch/node-temp#remove_tmpdir_dep":
+ version "0.8.3"
+- resolved "git+ssh://git@github.com/adam-lynch/node-temp.git#279c1350cb7e4f02515d91da9e35d39a40774016"
++ resolved "git+https://github.com/adam-lynch/node-temp.git#279c1350cb7e4f02515d91da9e35d39a40774016"
+ dependencies:
+ rimraf "~2.2.6"
+
+@@ -7994,7 +7994,7 @@ vinyl@^3.0.0:
+
+ "vtt.js@git+https://github.com/gkatsev/vtt.js.git#vjs-v0.12.1":
+ version "0.12.1"
+- resolved "git+ssh://git@github.com/gkatsev/vtt.js.git#8ea664e257ec7b5c092f58ac989e3134ff536a7a"
++ resolved "git+https://github.com/gkatsev/vtt.js.git#8ea664e257ec7b5c092f58ac989e3134ff536a7a"
+
+ w-json@^1.3.10:
+ version "1.3.10"