summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÓscar García Amor2019-10-15 10:08:07 +0200
committerÓscar García Amor2019-10-15 10:08:07 +0200
commit9e6716f80f8d9c8f31cbebf0c11128dea4819cac (patch)
tree0382443c800331b1445a04ed111e67c2ae2e6b18
parenta3cb40f633ee9bb97f33f27a7a2bda04ea0126f1 (diff)
downloadaur-9e6716f80f8d9c8f31cbebf0c11128dea4819cac.tar.gz
upgpkg: pidgin-sipe 1.25.0-2
Fix configure issue
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
-rw-r--r--pidgin-sipe-fix-359.patch22
3 files changed, 36 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3e65a4912e0..f06977d6e00d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pidgin-sipe
pkgdesc = Third-party Pidgin plugin for Microsoft Office 365/Lync/LCS/OCS
pkgver = 1.25.0
- pkgrel = 1
+ pkgrel = 2
url = https://sipe.sourceforge.net/
arch = x86_64
license = GPL2
@@ -11,7 +11,9 @@ pkgbase = pidgin-sipe
optdepends = freerdp: Desktop sharing
optdepends = krb5: Kerberos support
source = https://downloads.sourceforge.net/project/sipe/sipe/pidgin-sipe-1.25.0/pidgin-sipe-1.25.0.tar.bz2
+ source = pidgin-sipe-fix-359.patch
sha256sums = 5a42810e447c3af2632961e88d7c683b6619aeda03accdcbaad222d8337ec676
+ sha256sums = 2a99e91d42433adbb166b2af5c433fa3a596124555cf3fef31141da8884e2cb4
pkgname = pidgin-sipe
diff --git a/PKGBUILD b/PKGBUILD
index 1f095ca1ceab..4955e391bde1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=pidgin-sipe
pkgver=1.25.0
-pkgrel=1
+pkgrel=2
pkgdesc="Third-party Pidgin plugin for Microsoft Office 365/Lync/LCS/OCS"
arch=('x86_64')
license=('GPL2')
@@ -16,11 +16,16 @@ url="https://sipe.sourceforge.net/"
depends=('gmime' 'libpurple')
makedepends=('intltool')
optdepends=('freerdp: Desktop sharing' 'krb5: Kerberos support')
-source=(https://downloads.sourceforge.net/project/sipe/sipe/$pkgname-$pkgver/$pkgname-$pkgver.tar.bz2)
-sha256sums=('5a42810e447c3af2632961e88d7c683b6619aeda03accdcbaad222d8337ec676')
+source=("https://downloads.sourceforge.net/project/sipe/sipe/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.bz2"
+ "${pkgname}-fix-359.patch")
+sha256sums=('5a42810e447c3af2632961e88d7c683b6619aeda03accdcbaad222d8337ec676'
+ '2a99e91d42433adbb166b2af5c433fa3a596124555cf3fef31141da8884e2cb4')
build() {
- cd $pkgname-$pkgver
+ cd "${pkgname}-${pkgver}"
+
+ # Fix #359: Incorrect build due to false negative configure checks
+ patch -p1 <"${srcdir}/${pkgname}-fix-359.patch"
./configure --prefix=/usr --disable-telepathy
@@ -28,7 +33,7 @@ build() {
}
package() {
- cd $pkgname-$pkgver
+ cd "${pkgname}-${pkgver}"
- make DESTDIR="$pkgdir" install
+ make DESTDIR="${pkgdir}" install
}
diff --git a/pidgin-sipe-fix-359.patch b/pidgin-sipe-fix-359.patch
new file mode 100644
index 000000000000..88c86bf478dd
--- /dev/null
+++ b/pidgin-sipe-fix-359.patch
@@ -0,0 +1,22 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -336,7 +336,8 @@ PKG_CHECK_MODULES(LIBXML2, [libxml-2.0])
+ dnl assumption check: sizof(uuid_t) must be 16 (see uuid.c)
+ AC_MSG_CHECKING([that sizeof(uuid_t) is 16])
+ ac_save_CFLAGS="$CFLAGS"
+-CFLAGS="$CFLAGS $GLIB_CFLAGS $QUALITY_CFLAGS"
++dnl NOTE: including $QUALITY_CFLAGS can lead to false negative configure checks!
++CFLAGS="$CFLAGS $GLIB_CFLAGS"
+ dnl note the [[[ quoting: our code contains []!
+ AC_RUN_IFELSE(
+ [AC_LANG_PROGRAM(
+@@ -415,7 +416,8 @@ AS_IF([test "x$enable_purple" != xno],
+
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_LIBS="$LIBS"
+- CFLAGS="$CFLAGS $PURPLE_CFLAGS $QUALITY_CFLAGS"
++ dnl NOTE: including $QUALITY_CFLAGS can lead to false negative configure checks!
++ CFLAGS="$CFLAGS $PURPLE_CFLAGS"
+ LIBS="$LIBS $PURPLE_LIBS"
+
+ dnl check whether enable voice and video support