summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2023-02-05 10:54:23 +0100
committerChristopher Arndt2023-02-05 10:54:23 +0100
commit9e71200c2ae7071c59c238871e018033726b6b08 (patch)
tree528ec30290dd9a8330af5f304203241e5c15d804
parent26521bb61484752186431372b22e980444497e5d (diff)
downloadaur-9e71200c2ae7071c59c238871e018033726b6b08.tar.gz
New upstream version 1.4.90
* use pep-517 compliant build * license.txt file now included in source dist * PKGBUILD syntax clean-up
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD40
3 files changed, 28 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 746d12b074cf..e71ea15143a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = python-guizero
pkgdesc = Python module to allow learners to easily create GUIs
- pkgver = 1.3.0
+ pkgver = 1.4.0
pkgrel = 1
url = https://github.com/lawsie/guizero
arch = any
license = BSD
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-pillow
depends = tk
- source = https://files.pythonhosted.org/packages/source/g/guizero/guizero-1.3.0.tar.gz
- source = https://raw.githubusercontent.com/lawsie/guizero/master/license.txt
- md5sums = cb99d284c41da99f1f0ec75201eb8933
- md5sums = 9670acd16790b84f21178f2b940a96e2
+ source = https://files.pythonhosted.org/packages/source/g/guizero/guizero-1.4.0.tar.gz
+ sha256sums = 5764e38a3b2a089712ec1e75340bf8335ea7721e37df8d9021cdd0afb8b57a27
pkgname = python-guizero
diff --git a/.gitignore b/.gitignore
index c77b14fdca21..8574b3033911 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,8 +1,5 @@
-pkg
-src
-license.txt
guizero-*.tar.gz
-python-guizero-*.pkg.tar.xz
-python-guizero-*.pkg.tar.zst
+pkg/
+python-guizero-*.pkg.tar.*
python-guizero-*.src.tar.gz
-.AURINFO
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 9228bbf5987a..05be03c998ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,29 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
-pkgname='python-guizero'
-_module='guizero'
-pkgver=1.3.0
+_name=guizero
+pkgname=python-$_name
+pkgver=1.4.0
pkgrel=1
-pkgdesc="Python module to allow learners to easily create GUIs"
-url="https://github.com/lawsie/guizero"
-depends=('python-pillow' 'tk')
-makedepends=('python-setuptools')
-license=('BSD')
-arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/${_module}/${_module}-${pkgver}.tar.gz"
- 'https://raw.githubusercontent.com/lawsie/guizero/master/license.txt')
-md5sums=('cb99d284c41da99f1f0ec75201eb8933'
- '9670acd16790b84f21178f2b940a96e2')
+pkgdesc='Python module to allow learners to easily create GUIs'
+url='https://github.com/lawsie/guizero'
+depends=(python-pillow tk)
+makedepends=(python-build python-installer python-setuptools python-wheel)
+license=(BSD)
+arch=(any)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('5764e38a3b2a089712ec1e75340bf8335ea7721e37df8d9021cdd0afb8b57a27')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py build
+ cd $_name-$pkgver
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- # install license file
- install -Dm644 "$srcdir/license.txt" -t "$pkgdir/usr/share/licenses/$pkgname"
- # install readme into docdir
- install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ cd $_name-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ # install license file
+ install -Dm644 license.txt -t "$pkgdir"/usr/share/licenses/$pkgname
+ # install readme into docdir
+ install -Dm644 README.md -t "$pkgdir"/usr/share/doc/$pkgname
}