summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2020-09-07 23:57:20 +0200
committerPieter Goetschalckx2020-09-07 23:57:20 +0200
commit9f0a53030c4c8f1b15336907e0c95e58c5d37ce7 (patch)
tree4e38874af6a466710a67ed108fd7d95bce3b9e2e
parent5fb7357a6904d47b22f5d0ac63d6aa3de808e5bd (diff)
downloadaur-9f0a53030c4c8f1b15336907e0c95e58c5d37ce7.tar.gz
v0.1.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f21fb261798..98db313cba08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = fx_cast
pkgdesc = Implementation of the Chrome Sender API (Chromecast) within Firefox
- pkgver = 0.0.7
+ pkgver = 0.1.0
pkgrel = 1
url = https://hensm.github.io/fx_cast/
arch = x86_64
license = MIT
makedepends = npm
+ depends = avahi
conflicts = fx_cast-bin
options = !strip
- source = https://github.com/hensm/fx_cast/archive/v0.0.7.tar.gz
- sha256sums = d9dbcf9594e343b2e5ccc901a1bf5659b1a98cdce4e0910833d1d27872eb5efe
+ source = https://github.com/hensm/fx_cast/archive/v0.1.0.tar.gz
+ sha256sums = 529425e78208e6acfe54284c1ca145ff1781daf627334939630b31cc53234be7
pkgname = fx_cast
diff --git a/PKGBUILD b/PKGBUILD
index 87b804b5d8da..b4e4a4c1ddeb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,18 @@
# Contributor: csicar
pkgname=fx_cast
-pkgver=0.0.7
+pkgver=0.1.0
pkgrel=1
pkgdesc="Implementation of the Chrome Sender API (Chromecast) within Firefox"
arch=('x86_64')
url="https://hensm.github.io/fx_cast/"
license=('MIT')
makedepends=('npm')
+depends=('avahi')
conflicts=('fx_cast-bin')
options=('!strip')
source=("https://github.com/hensm/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('d9dbcf9594e343b2e5ccc901a1bf5659b1a98cdce4e0910833d1d27872eb5efe')
+sha256sums=('529425e78208e6acfe54284c1ca145ff1781daf627334939630b31cc53234be7')
build() {
cd "${pkgname}-${pkgver}"
@@ -20,14 +21,16 @@ build() {
sed -i 's/`node.*`/"host"/' app/bin/build.js
npm install --cache "${srcdir}/npm-cache"
npm run build:app
- sed -i 's#"path":.*$#"path": "/usr/lib/fx_cast/fx_cast_bridge"#' dist/app/fx_cast_bridge.json
+ sed -i 's#"path":.*$#"path": "/usr/lib/fx_cast/fx_cast_bridge.sh"#' dist/app/fx_cast_bridge.json
}
package() {
cd "${pkgname}-${pkgver}"
- install -Dm755 dist/app/fx_cast_bridge -t "${pkgdir}/usr/lib/fx_cast/"
- install -Dm755 dist/app/dns_sd_bindings.node -t "${pkgdir}/usr/lib/fx_cast/"
+ install -Dm755 dist/app/{fx_cast_bridge.sh,package.json} -t "${pkgdir}/usr/lib/fx_cast/"
+ cp -r dist/app/src "${pkgdir}/usr/lib/fx_cast/"
+ cp -r app/node_modules "${pkgdir}/usr/lib/fx_cast/"
+
install -Dm644 dist/app/fx_cast_bridge.json "${pkgdir}/usr/lib/mozilla/native-messaging-hosts/fx_cast_bridge.json"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}