summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormrtc02019-06-17 16:58:55 +0900
committermrtc02019-06-17 16:58:55 +0900
commit9f1a52424010c415b24d6da29a10cf09b5671223 (patch)
treedac1f7ba009964d099855af6f7d56a33ef01fa95
downloadaur-9f1a52424010c415b24d6da29a10cf09b5671223.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1980c6d7274
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = haconiwa-git
+ pkgdesc = MRuby on Container / A Linux container runtime using mruby DSL for configuration, control and hooks http://haconiwa.mruby.org/
+ pkgver = v0.10.2.r15.g375a79b
+ pkgrel = 1
+ url = https://github.com/haconiwa/haconiwa
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = libcgroup
+ makedepends = criu
+ makedepends = oniguruma
+ depends = libcgroup
+ depends = criu
+ depends = oniguruma
+ conflicts = haconiwa
+ source = haconiwa-git::git+https://github.com/haconiwa/haconiwa
+ md5sums = SKIP
+
+pkgname = haconiwa-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f686354eb0b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Kohei Morita <mrtc0@ssrf.in>
+pkgname=haconiwa-git
+pkgver=v0.10.2.r15.g375a79b
+pkgrel=1
+pkgdesc="MRuby on Container / A Linux container runtime using mruby DSL for configuration, control and hooks http://haconiwa.mruby.org/"
+arch=('x86_64')
+url="https://github.com/haconiwa/haconiwa"
+license=('GPL')
+depends=('libcgroup' 'criu' 'oniguruma')
+makedepends=('git' 'libcgroup' 'criu' 'oniguruma')
+conflicts=("${pkgname%-git}")
+source=('haconiwa-git::git+https://github.com/haconiwa/haconiwa')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${pkgname}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+ make PREFIX="${pkgdir}/usr/" install
+}