summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTambet Arak2019-01-12 17:21:04 +0200
committerTambet Arak2019-01-12 17:29:59 +0200
commit9f2b1c33cf0c227aaf1829011e96429da5352a52 (patch)
tree5ec3d4b13ec534fd9b681834e519d86218a5d24d
parent6600ebb7cb2c201912cf6773af9d42d4eb3b4afb (diff)
downloadaur-9f2b1c33cf0c227aaf1829011e96429da5352a52.tar.gz
Update to 4.4.1, migrate to dune
Adopted and cleaned up the PKGBUILD.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD54
2 files changed, 28 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6ee451ddfa2..408fc21b10e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,18 @@
pkgbase = ocaml-sqlite3
pkgdesc = SQLite3 bindings for OCaml
- pkgver = 4.4.0
+ pkgver = 4.4.1
pkgrel = 1
url = https://github.com/mmottl/sqlite3-ocaml
- arch = i686
arch = x86_64
license = MIT
- makedepends = ocaml
makedepends = ocaml-findlib
- makedepends = sqlite3
- makedepends = ocamlbuild
- makedepends = jbuilder
- makedepends = opam
- options = !makeflags
- options = staticlibs
- source = https://github.com/mmottl/sqlite3-ocaml/archive/4.4.0.tar.gz
- md5sums = 2956d5696d45229a470e0f6e7409c876
+ makedepends = dune
+ depends = ocaml
+ depends = ocaml-base
+ depends = ocaml-stdio
+ depends = sqlite3
+ source = https://github.com/mmottl/sqlite3-ocaml/archive/4.4.1.tar.gz
+ md5sums = 70ffbf667411876e13071e85d6f20ca7
pkgname = ocaml-sqlite3
diff --git a/PKGBUILD b/PKGBUILD
index eccdf6d7dc49..b20f6d050b68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,34 @@
-# Maintainer: oliver < a t > first . in-berlin . de
+# Maintainer: Tambet Arak <tambetarak+nospam@gmail.com>
+# Contributor: oliver < a t > first . in-berlin . de
# Contributor: charlesthehawk at yahoo dot com
# Contributor: Serge Zirukin <ftrvxmtrx@gmail.com>
pkgname=ocaml-sqlite3
_pkgname=sqlite3-ocaml
-pkgver=4.4.0
+pkgver=4.4.1
pkgrel=1
-pkgdesc="SQLite3 bindings for OCaml"
-arch=('i686' 'x86_64')
-url="https://github.com/mmottl/sqlite3-ocaml"
+arch=('x86_64')
license=('MIT')
-makedepends=('ocaml' 'ocaml-findlib' 'sqlite3' 'ocamlbuild' 'jbuilder' 'opam')
-source=(https://github.com/mmottl/sqlite3-ocaml/archive/${pkgver}.tar.gz)
-md5sums=('2956d5696d45229a470e0f6e7409c876')
-options=('!makeflags' 'staticlibs')
-
-_pkgdir="$_pkgname-$pkgver"
-
-build () {
- echo ${srcdir}/${_pkgname}-${pkgver}
- cd ${srcdir}/${_pkgname}-${pkgver}
- opam init -n --comp 4.07.0
- eval `opam config env`
- opam install base
- opam install stdio
- opam install configurator
-
- make all
+pkgdesc='SQLite3 bindings for OCaml'
+url='https://github.com/mmottl/sqlite3-ocaml'
+depends=('ocaml' 'ocaml-base' 'ocaml-stdio' 'sqlite3')
+makedepends=('ocaml-findlib' 'dune')
+options=()
+source=("https://github.com/mmottl/sqlite3-ocaml/archive/${pkgver}.tar.gz")
+md5sums=('70ffbf667411876e13071e85d6f20ca7')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ dune build @install
}
package() {
- cd ${srcdir}/${_pkgname}-${pkgver}
- cd _build/install/default/lib/sqlite3
-
- INSTALLDIR="${pkgdir}$(ocamlfind printconf destdir)"
- echo Install-Dir: ${INSTALLDIR}
- mkdir -p "$INSTALLDIR"
- chmod 755 "$INSTALLDIR"
+ cd "$srcdir/$_pkgname-$pkgver"
- # src/sqlite3-ocaml-4.4.0/_build/install/default/lib/sqlite3/
+ mkdir -p "$pkgdir/usr"
+ mkdir -p "$pkgdir/$(ocamlfind printconf destdir)"
- env DESTDIR=${pkgdir} \
- OCAMLFIND_DESTDIR=${pkgdir}$(ocamlfind printconf destdir) \
- OCAMLFIND_LDCONF=ignore \
- ocamlfind install sqlite3 *
+ dune install --prefix="$pkgdir/usr" \
+ --libdir="$pkgdir/$(ocamlfind printconf destdir)"
}