summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Richter2020-04-13 10:09:05 +0200
committerMarkus Richter2020-04-13 10:09:05 +0200
commit9f3d7cfda49d50c3fc86fa6de7d6983e97a79094 (patch)
treeb2d12695bf5e68f7db3a0fc341de6bcf62860558
parent9b03f3117e2a9350ae04726cab1f2cdc0388f32e (diff)
downloadaur-9f3d7cfda49d50c3fc86fa6de7d6983e97a79094.tar.gz
Fix rustup toolchain issues (mainly on ARM)
Works around https://github.com/dani-garcia/bitwarden_rs/issues/962
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc2a2a1d6d5c..eb4f21c8c24d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bitwarden_rs
pkgdesc = An unofficial lightweight implementation of the bitwarden-server using rust and sqlite. Does NOT include the web-interface.
pkgver = 1.14.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dani-garcia/bitwarden_rs
install = bitwarden_rs.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 53f58b48e1ad..46fd2de6a224 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=bitwarden_rs
_pkgbase=bitwarden_rs
pkgver=1.14.2
-pkgrel=1
+pkgrel=2
pkgdesc="An unofficial lightweight implementation of the bitwarden-server using rust and sqlite. Does NOT include the web-interface."
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://github.com/dani-garcia/bitwarden_rs"
@@ -29,13 +29,18 @@ sha512sums=('242f10592dec87b83cd9ea360dc83901cb8adaf019c9220ea910824d8f9a7d98c71
'9fde678747d120704d0d99751af1eebd89ba2643af5917da9d9d2a8712fe5bb6ef1d3545d3b669467d14cab51c0c1514853364f323ff92bab7e7ed8501fe5b56')
_src="$pkgname-$pkgver"
-
-
build() {
+ # rustup is not required, but if it exists, we have to set the profile. Otherwise, fail silently.
+ # This is necessary because some of the optional toolchain components (e.g. clippy) fail regularly on nightly and rustup/cargo will fail if it can't download those.
+ RUSTUP_PROFILE=`rustup show profile 2>/dev/null`
+ rustup set profile minimal 2>/dev/null && echo "Set rustup profile to 'minimal'. Will reset to '$RUSTUP_PROFILE' after a successful build."
+
#build bitwarden_rs
cd "$srcdir/$_src"
patch -N -p1 -i "$srcdir/0001-Disable-Vault.patch"
cargo build --release --locked --features sqlite
+
+ rustup set profile $RUSTUP_PROFILE 2>/dev/null && echo "Set rustup profile back to '$RUSTUP_PROFILE'."
}
check() {