summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteve Engledow2020-07-24 15:17:51 +0100
committerSteve Engledow2020-07-24 15:17:51 +0100
commit9f4a44e464b3a9f4a90084ffa0771bb0be978fc7 (patch)
treea99084675b57fa06216971c6162dff9658947dbb
downloadaur-9f4a44e464b3a9f4a90084ffa0771bb0be978fc7.tar.gz
Add initial version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
-rw-r--r--progress-quest9
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97970cac98d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = progress-quest-bin
+ pkgdesc = Progress Quest is an antic and fantastical computer role-playing game
+ pkgver = 6.2
+ pkgrel = 1
+ url = http://progressquest.com/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = unzip
+ depends = wine
+ source = http://www.grumdrig.com/dl/pq6-2.zip
+ source = progress-quest
+ sha256sums = 85f8e5e4735f0faf8d84ac1267ec64a9a92265a9033dd3c93d988dbe3eb1c716
+ sha256sums = 91fc83b000b581fd29295d99ab3253b40e6f6a94f39c557ae7ed80f7c8bb5702
+
+pkgname = progress-quest-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d89a9dcb710d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Steve Engledow <steve@engledow.me>
+pkgname=progress-quest-bin
+pkgver=6.2
+pkgrel=1
+pkgdesc='Progress Quest is an antic and fantastical computer role-playing game'
+arch=('i686' 'x86_64')
+url='http://progressquest.com/'
+license=('MIT')
+makedepends=('unzip')
+depends=('wine')
+source=(
+ 'http://www.grumdrig.com/dl/pq6-2.zip'
+ 'progress-quest'
+)
+sha256sums=(
+ '85f8e5e4735f0faf8d84ac1267ec64a9a92265a9033dd3c93d988dbe3eb1c716'
+ '91fc83b000b581fd29295d99ab3253b40e6f6a94f39c557ae7ed80f7c8bb5702'
+)
+
+package() {
+ install -Dm755 "pq.exe" "$pkgdir/usr/share/progress-quest/pq.exe"
+ install -Dm755 "progress-quest" "$pkgdir/usr/bin/progress-quest"
+}
diff --git a/progress-quest b/progress-quest
new file mode 100644
index 000000000000..7d499854a6a8
--- /dev/null
+++ b/progress-quest
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+CONFIG_DIR="$HOME/.progress-quest"
+
+mkdir -p "$CONFIG_DIR"
+
+cd "$CONFIG_DIR"
+
+wine /usr/share/progress-quest/pq.exe