summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVyacheslav Razykov2022-07-04 04:54:59 +0300
committerVyacheslav Razykov2022-07-04 04:54:59 +0300
commit9f597c319473b440a31ee6727b3b3f4e2db650bf (patch)
tree38e145c2d0f4b07b8d736cd219a16cb49c7bc615
parentc15fbeda3ce0c0935738651608ceddcd16ad5132 (diff)
downloadaur-9f597c319473b440a31ee6727b3b3f4e2db650bf.tar.gz
Update to 2.38-2
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 5 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b1ea8bad234..1b59fb6855c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = arm-linux-gnueabihf-binutils
pkgdesc = A set of programs to assemble and manipulate binary and object files (arm-linux-gnueabihf)
pkgver = 2.38
- pkgrel = 1
+ pkgrel = 2
url = https://www.gnu.org/software/binutils/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 58f187939b13..b513f93cc670 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,4 @@
+# Maintainer: Vyacheslav Razykov <v.razykov@gmail.com>
# Contributor: Alexander 'hatred' Drozdov <adrozdoff@gmail.com>
# Contributor: toha257 <toha257@gmail.com>
# Contributor: Allan McRae <allan@archlinux.org>
@@ -5,21 +6,18 @@
# Contributor: Kevin Mihelich <kevin@archlinuxarm.org>
# Contributor: Felipe Balbi <felipe@balbi.sh>
# Contributor: Tavian Barnes <tavianator@tavianator.com>
-# Maintainer: Vyacheslav Razykov <v.razykov@gmail.com>
_target="arm-linux-gnueabihf"
pkgname=${_target}-binutils
pkgver=2.38
-pkgrel=1
+pkgrel=2
pkgdesc="A set of programs to assemble and manipulate binary and object files (${_target})"
arch=(i686 x86_64)
url='https://www.gnu.org/software/binutils/'
license=(GPL)
depends=(glibc zlib elfutils)
-#makedepends=('elfutils')
options=(staticlibs !distcc !ccache)
source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.xz{,.sig})
-#source=(https://ftpmirror.gnu.org/gnu/binutils/binutils-$pkgver.tar.xz{,.sig})
sha256sums=('e316477a914f567eccc34d5d29785b8b0f5a10208d36bbacedcc39048ecfe024'
'SKIP')
validpgpkeys=(3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F)
@@ -27,7 +25,6 @@ validpgpkeys=(3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F)
prepare() {
mkdir -p binutils-build
- #cd binutils-gdb
cd binutils-$pkgver
# Turn off development mode (-Werror, gas run-time checks, date in sonames)
@@ -35,8 +32,6 @@ prepare() {
# hack! - libiberty configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
-
- #patch -Np1 -i ../binutils-cb5f6a3e146cc70bc2d864989386df80acec5d3e.patch
}
build() {
@@ -45,7 +40,7 @@ build() {
"$srcdir/binutils-$pkgver/configure" \
--prefix=/usr \
--program-prefix=${_target}- \
- --with-lib-path=/usr/lib/binutils/${_target} \
+ --with-lib-path=/usr/lib/binutils/${_target}:/usr/${_target}/lib \
--with-local-prefix=/usr/lib/${_target} \
--with-sysroot=/usr/${_target} \
--enable-deterministic-archives \
@@ -54,6 +49,7 @@ build() {
--enable-lto \
--enable-plugins \
--enable-relro \
+ --enable-targets=${_target} \
--enable-threads \
--disable-gdb \
--disable-werror \