summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcent2022-10-25 14:27:38 +0000
committercent2022-10-25 14:27:38 +0000
commit9f63d36f2ad8a8a692351a0543edd623bf283bd0 (patch)
tree9310ef7dd24fd4afab8c9ed54b16b718cc3c4832
parentebbe6fc0916d40f7f7ee2603306b356a3d6746d1 (diff)
downloadaur-9f63d36f2ad8a8a692351a0543edd623bf283bd0.tar.gz
sync from github
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07f9dfaf632a..1ea108e67720 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = xivlauncher
pkgdesc = Custom Launcher for Final Fantasy XIV Online (Crossplatform rewrite)
- pkgver = 1.0.1.0
+ pkgver = 1.0.2
pkgrel = 1
epoch = 1
- url = https://github.com/goatcorp/FFXIVQuickLauncher/
+ url = https://github.com/goatcorp/XIVLauncher.Core
arch = x86_64
license = GPL
makedepends = dotnet-sdk>=6
@@ -46,7 +46,7 @@ pkgbase = xivlauncher
depends = jxrlib
optdepends = steam
options = !strip
- source = FFXIVQuickLauncher::git+https://github.com/goatcorp/FFXIVQuickLauncher.git#commit=6246fde6b54f8c7e340057fe2d940287c437153f
+ source = XIVLauncher.Core::git+https://github.com/goatcorp/XIVLauncher.Core.git#tag=1.0.2
source = XIVLauncher.desktop
sha512sums = SKIP
sha512sums = 5ac774f858d4015c59e6758e2a706b93e822bca9c046ed87210deabc141ac101020d2654fbcf8314f9409a4cfcf921d1e26ec0a3b0beab02d1bcd045fb6e6f14
diff --git a/PKGBUILD b/PKGBUILD
index d7a9d5f15aca..d0dafeb003c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,11 @@
# Maintainer: Vincent Post <cent@spline.de>
pkgname=xivlauncher
-pkgver=1.0.1.0
-_pkgver=6246fde6b54f8c7e340057fe2d940287c437153f
+pkgver=1.0.2
pkgrel=1
epoch=1
pkgdesc="Custom Launcher for Final Fantasy XIV Online (Crossplatform rewrite)"
arch=('x86_64')
-url='https://github.com/goatcorp/FFXIVQuickLauncher/'
+url='https://github.com/goatcorp/XIVLauncher.Core'
license=('GPL')
depends=(
'aria2'
@@ -33,7 +32,7 @@ makedepends=('dotnet-sdk>=6' 'git')
optdepends=('steam')
options=('!strip')
source=(
- "FFXIVQuickLauncher::git+https://github.com/goatcorp/FFXIVQuickLauncher.git#commit=${_pkgver}"
+ "XIVLauncher.Core::git+https://github.com/goatcorp/XIVLauncher.Core.git#tag=${pkgver}"
"XIVLauncher.desktop"
)
sha512sums=(
@@ -41,9 +40,14 @@ sha512sums=(
'5ac774f858d4015c59e6758e2a706b93e822bca9c046ed87210deabc141ac101020d2654fbcf8314f9409a4cfcf921d1e26ec0a3b0beab02d1bcd045fb6e6f14'
)
+prepare() {
+ cd "${srcdir}/XIVLauncher.Core"
+ git submodule update --init --recursive
+}
+
build() {
mkdir -p "${srcdir}/build"
- cd "${srcdir}/FFXIVQuickLauncher/src/XIVLauncher.Core/"
+ cd "${srcdir}/XIVLauncher.Core/src/XIVLauncher.Core/"
dotnet publish -r linux-x64 --sc -o "${srcdir}/build" --configuration Release -p:DefineConstants=WINE_XIV_ARCH_LINUX
}
@@ -51,7 +55,7 @@ package() {
install -d "${pkgdir}/usr/bin/"
install -d "${pkgdir}/opt/XIVLauncher/"
install -D -m644 "${srcdir}/XIVLauncher.desktop" "${pkgdir}/usr/share/applications/XIVLauncher.desktop"
- install -D -m644 "${srcdir}/FFXIVQuickLauncher/src/XIVLauncher.Core/Resources/logo.png" "${pkgdir}/usr/share/pixmaps/xivlauncher.png"
+ install -D -m644 "${srcdir}/XIVLauncher.Core/misc/linux_distrib/512.png" "${pkgdir}/usr/share/pixmaps/xivlauncher.png"
cp -r "${srcdir}/build/." "${pkgdir}/opt/XIVLauncher/"
ln -s ../../opt/XIVLauncher/XIVLauncher.Core "${pkgdir}/usr/bin/XIVLauncher.Core"
}