summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-12-11 03:36:09 +0100
committerGustavo Alvarez2016-12-11 03:36:09 +0100
commit9f64733dbb2030b6e4a9222af79c07cb3eb5da35 (patch)
treeed794f264d4411f249bc3ff3603d87c319cacbe9
downloadaur-9f64733dbb2030b6e4a9222af79c07cb3eb5da35.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD62
-rw-r--r--tsmuxergui.desktop9
-rw-r--r--tsmuxergui.pngbin0 -> 43305 bytes
5 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8c9427dc487
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Sun Dec 11 02:36:08 UTC 2016
+pkgbase = tsmuxer-ng-bin
+ pkgdesc = Transport Stream muxer. New Generation (3D capable)
+ pkgver = 2.6.11
+ pkgrel = 3
+ url = http://forum.doom9.org/showthread.php?t=168539
+ arch = i686
+ arch = x86_64
+ license = custom
+ options = !strip
+ source = tsmuxer-2.6.11.tar.gz::https://docs.google.com/uc?authuser=0&id=0B0VmPcEZTp8NekJxLUVJRWMwejQ&export=download
+ source = tsmuxergui.desktop
+ source = tsmuxergui.png
+ sha256sums = 815a383aebc67e59b6e541b927ce14480efed9d103fe99e74ced9ea381f61764
+ sha256sums = aed84b10da52849c14acb6bfb8b806c9675e4c8bcf781590712bbedc332b443f
+ sha256sums = 5d1a6b9e88a82d40a0159d95bb596a7dc4502d7164364098e4cc3ddef72632c0
+
+pkgname = tsmuxer-cli-ng-bin
+
+pkgname = tsmuxer-gui-ng-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e1463eaaa13e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!tsmuxergui.desktop
+!tsmuxergui.png
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf138d08b604
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgbase=tsmuxer-ng-bin
+pkgname=('tsmuxer-cli-ng-bin'
+ 'tsmuxer-gui-ng-bin'
+ )
+pkgver=2.6.11
+pkgrel=3
+pkgdesc="Transport Stream muxer. New Generation (3D capable)"
+arch=('i686' 'x86_64')
+url='http://forum.doom9.org/showthread.php?t=168539'
+license=('custom')
+source=("tsmuxer-${pkgver}.tar.gz::https://docs.google.com/uc?authuser=0&id=0B0VmPcEZTp8NekJxLUVJRWMwejQ&export=download"
+ 'tsmuxergui.desktop'
+ 'tsmuxergui.png'
+ )
+sha256sums=('815a383aebc67e59b6e541b927ce14480efed9d103fe99e74ced9ea381f61764'
+ 'aed84b10da52849c14acb6bfb8b806c9675e4c8bcf781590712bbedc332b443f'
+ '5d1a6b9e88a82d40a0159d95bb596a7dc4502d7164364098e4cc3ddef72632c0'
+ )
+options=('!strip')
+
+package_tsmuxer-cli-ng() {
+ pkgdesc="Transport Stream muxer. New Generation (3D capable). CLI"
+ depends_i686=('gcc-libs'
+ 'freetype2'
+ )
+ depends_x86_64=('lib32-gcc-libs'
+ 'lib32-freetype2'
+ )
+ provides=('tsmuxer-cli'
+ 'tsmuxer-cli-bin'
+ )
+ conflicts=('tsmuxer'
+ 'tsmuxer-cli'
+ )
+
+ install -Dm755 tsMuxeR "${pkgdir}/usr/bin/tsmuxer"
+ (cd ${pkgdir}/usr/bin; upx -d -q tsmuxer &>/dev/null)
+}
+
+package_tsmuxer-gui-ng() {
+ pkgdesc="Transport Stream muxer. New Generation (3D capable). GUI"
+ depends_i686=('gcc-libs'
+ 'qt4'
+ )
+ depends_x86_64=('lib32-gcc-libs'
+ 'lib32-qt4'
+ )
+ provides=('tsmuxer-gui-bin'
+ 'tsmuxer-gui'
+ )
+ conflicts=('tsmuxer'
+ 'tsmuxer-gui'
+ )
+
+ install -Dm755 tsMuxerGUI "${pkgdir}/usr/bin/tsmuxergui"
+ (cd ${pkgdir}/usr/bin; upx -d -q tsmuxergui &>/dev/null)
+
+ install -Dm644 tsmuxergui.desktop "${pkgdir}/usr/share/applications/tsmuxergui.desktop"
+ install -Dm644 tsmuxergui.png "${pkgdir}/usr/share/pixmaps/tsMuxergui.png"
+}
diff --git a/tsmuxergui.desktop b/tsmuxergui.desktop
new file mode 100644
index 000000000000..533db902b4a9
--- /dev/null
+++ b/tsmuxergui.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=tsMuxerGUI
+Comment=Transport Stream muxer. New Generation (3D capable) GUI
+Exec=tsmuxergui
+Icon=tsmuxergui
+Terminal=false
+StartupNotify=false
+Categories=Qt;AudioVideo;Audio;AudioVideoEditing;
diff --git a/tsmuxergui.png b/tsmuxergui.png
new file mode 100644
index 000000000000..959f5906dafa
--- /dev/null
+++ b/tsmuxergui.png
Binary files differ