summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-07 13:42:21 +0800
committerzxp198210052024-02-07 13:42:21 +0800
commit9f67e2db076c883256e7ed8719ea5eeb1bb0f07b (patch)
tree659eb05d74f862d3729d09b8569df53f38292060
parent6904072e6cad28c767bf0f7f20da2a8a40606b2b (diff)
downloadaur-9f67e2db076c883256e7ed8719ea5eeb1bb0f07b.tar.gz
fix errors
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD34
-rw-r--r--gstarcad.sh5
3 files changed, 12 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87777b5b16b2..254fdb8be787 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,47 +1,23 @@
pkgbase = gstarcad-bin
pkgdesc = 浩辰 CAD.Free trial for 30 days
pkgver = 24.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.gstarcad.com/cad_linux
arch = aarch64
arch = x86_64
- license = custom
- depends = libxxf86vm
- depends = libsm
+ license = LicenseRef-custom
depends = hicolor-icon-theme
- depends = libxkbcommon
- depends = xcb-util-image
- depends = xdg-utils
- depends = xcb-util-keysyms
- depends = fontconfig
- depends = libcups
- depends = xcb-util-wm
- depends = libice
- depends = xcb-util-renderutil
depends = qt5-base
- depends = freetype2
- depends = libxfixes
- depends = libxext
- depends = libxcb
- depends = expat
- depends = mesa
- depends = libxdamage
- depends = libx11
- depends = systemd-libs
- depends = libxshmfence
depends = qt5-svg
- depends = libxkbcommon-x11
- depends = libglvnd
- depends = libdrm
- depends = openssl-1.1
- depends = libpng12
depends = curl
depends = sqlite
+ depends = openssl-1.1
+ depends = libpng12
provides = gstarcad=24.1
conflicts = gstarcad
options = !strip
source = gstarcad.sh
- sha256sums = 95c9dc84df4bf3dc61400bf34e8fc2b36bf1b5e8d92496f3f15adc7576390c2f
+ sha256sums = 67d297b531dcc3b43061413944a2d425e2116d4527c7dd54ccf78a38cc90997e
source_aarch64 = gstarcad-24.1-aarch64.deb::https://official-cn.gstarcad.cn/linux/2024/sp1/deb/gstarcad_24.1_arm64.deb
sha256sums_aarch64 = bee290f7578d2c7ede25551b8ebf978834812d27fb1868dd8f800ae0f85656dc
source_x86_64 = gstarcad-24.1-x86_64.deb::https://official-cn.gstarcad.cn/linux/2024/sp1/deb/gstarcad_24.1_amd64.deb
diff --git a/PKGBUILD b/PKGBUILD
index bc6304246050..d6ede969975c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,55 +3,31 @@
pkgname=gstarcad-bin
pkgver=24.1
_subver=sp1
-pkgrel=1
+pkgrel=2
pkgdesc="浩辰 CAD.Free trial for 30 days"
arch=(
'aarch64'
'x86_64'
)
-license=('custom')
+license=('LicenseRef-custom')
url="https://www.gstarcad.com/cad_linux"
_downurl="https://official-cn.gstarcad.cn"
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
options=('!strip')
depends=(
- 'libxxf86vm'
- 'libsm'
'hicolor-icon-theme'
- 'libxkbcommon'
- 'xcb-util-image'
- 'xdg-utils'
- 'xcb-util-keysyms'
- 'fontconfig'
- 'libcups'
- 'xcb-util-wm'
- 'libice'
- 'xcb-util-renderutil'
'qt5-base'
- 'freetype2'
- 'libxfixes'
- 'libxext'
- 'libxcb'
- 'expat'
- 'mesa'
- 'libxdamage'
- 'libx11'
- 'systemd-libs'
- 'libxshmfence'
'qt5-svg'
- 'libxkbcommon-x11'
- 'libglvnd'
- 'libdrm'
- 'openssl-1.1'
- 'libpng12'
'curl'
'sqlite'
+ 'openssl-1.1'
+ 'libpng12'
)
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_downurl}/linux/2024/${_subver}/deb/${pkgname%-bin}_${pkgver}_arm64.deb")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_downurl}/linux/2024/${_subver}/deb/${pkgname%-bin}_${pkgver}_amd64.deb")
source=("${pkgname%-bin}.sh")
-sha256sums=('95c9dc84df4bf3dc61400bf34e8fc2b36bf1b5e8d92496f3f15adc7576390c2f')
+sha256sums=('67d297b531dcc3b43061413944a2d425e2116d4527c7dd54ccf78a38cc90997e')
sha256sums_aarch64=('bee290f7578d2c7ede25551b8ebf978834812d27fb1868dd8f800ae0f85656dc')
sha256sums_x86_64=('cac879546a1ad8aabad0246d95ea25f77b628a0879392f570269f50882a8e8b5')
build(){
diff --git a/gstarcad.sh b/gstarcad.sh
index d220961cc523..3f2230273329 100644
--- a/gstarcad.sh
+++ b/gstarcad.sh
@@ -33,6 +33,5 @@ _display_server_type=`echo ${WAYLAND_DISPLAY}`
if [ "${_display_server_type}" = "*wayland*" ]; then
export LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:${_APPDIR}/systemlibs/wayland"
fi
-cd "${_APPDIR}" || exit
-exec "${_RUNNAME}" "$@" | exit
-
+cd "${_APPDIR}"
+exec "${_RUNNAME}" "$@" || exit $? \ No newline at end of file