summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-10-31 15:25:57 +0100
committerbartus2018-10-31 15:26:50 +0100
commit9f770bbc44493fda2bb347dadda5433ae3c6dae4 (patch)
tree51ae8e6d8953863e17810575da6d375be50169d6
parent0a5bdfff47615b8d51685a43339cd671fc4f8438 (diff)
downloadaur-9f770bbc44493fda2bb347dadda5433ae3c6dae4.tar.gz
fix unambiguous distance()
downgrade python > python35
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--gcc-8.patch12
3 files changed, 24 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd5e9514869c..0ade85da83c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,7 @@ pkgbase = luxrender-hg
makedepends = mesa
makedepends = qt4
makedepends = luxrays-hg
- makedepends = python
+ makedepends = python35
makedepends = opencl-headers
makedepends = eos_portable_archive
makedepends = mercurial
@@ -25,17 +25,19 @@ pkgbase = luxrender-hg
depends = embree-bvh_build-git
optdepends = luxblend25: Blender exporter
optdepends = qt4: Qt GUI
- optdepends = python: pylux Python interface
+ optdepends = python35: pylux Python interface
optdepends = opencl-driver: OpenCL support
provides = luxrender
conflicts = luxrender
source = lux::hg+https://bitbucket.org/luxrender/lux#branch=default
source = boost-15500.patch
source = luxrender-gcc7.patch
+ source = gcc-8.patch
source = force_python3.diff
md5sums = SKIP
md5sums = b9e5c442093e69485752e6395c931b27
md5sums = fa680b0d621b42c8e7440056bf26ec1c
+ md5sums = 6b71588b2c3e05c8f5ddbac824a39530
md5sums = 42692e65eabc5828693e2682e94b7c64
pkgname = luxrender-hg
diff --git a/PKGBUILD b/PKGBUILD
index 60f271645c3f..ffe30df74f06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,19 +12,21 @@ depends=('boost-libs' 'freeimage' 'openexr' 'openimageio' 'libpng' 'opencl-icd-l
'embree-bvh_build-git')
optdepends=('luxblend25: Blender exporter' \
'qt4: Qt GUI' \
- 'python: pylux Python interface' \
+ 'python35: pylux Python interface' \
'opencl-driver: OpenCL support')
-makedepends=('cmake' 'boost' 'mesa' 'qt4' "luxrays-hg" 'python' 'opencl-headers'
+makedepends=('cmake' 'boost' 'mesa' 'qt4' "luxrays-hg" 'python35' 'opencl-headers'
'eos_portable_archive' 'mercurial')
provides=('luxrender')
conflicts=('luxrender')
source=('lux::hg+https://bitbucket.org/luxrender/lux#branch=default'
'boost-15500.patch'
'luxrender-gcc7.patch'
+ 'gcc-8.patch'
'force_python3.diff')
md5sums=('SKIP'
'b9e5c442093e69485752e6395c931b27'
'fa680b0d621b42c8e7440056bf26ec1c'
+ '6b71588b2c3e05c8f5ddbac824a39530'
'42692e65eabc5828693e2682e94b7c64')
pkgver() {
@@ -46,6 +48,9 @@ prepare() {
# fix deprecated function in boost,asio,basic_stream_socket::native() replace with native_handle()
patch -Np1 -i ${srcdir}/boost-15500.patch
+
+ # fix unambiguous 'distance' function in boost/gcc8-stl
+ patch -Np1 -i ${srcdir}/gcc-8.patch
}
build() {
@@ -53,7 +58,7 @@ build() {
mkdir -p build
cd build
- _pyver=$(python -c "from sys import version_info; print(\"%d.%d\" % (version_info[0],version_info[1]))")
+ _pyver=$(python3.5 -c "from sys import version_info; print(\"%d.%d\" % (version_info[0],version_info[1]))")
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
diff --git a/gcc-8.patch b/gcc-8.patch
new file mode 100644
index 000000000000..39abbec5d63e
--- /dev/null
+++ b/gcc-8.patch
@@ -0,0 +1,12 @@
+diff -r f56582df55f4 accelerators/bvhaccel.cpp
+--- a/accelerators/bvhaccel.cpp Sun Jul 23 13:46:05 2017 +0200
++++ b/accelerators/bvhaccel.cpp Wed Oct 31 15:07:44 2018 +0100
+@@ -146,7 +146,7 @@
+
+ vector<boost::shared_ptr<BVHAccelTreeNode> >::iterator it =
+ partition(list.begin()+splits[j], list.begin()+splits[j+1], bind2nd(ptr_fun(bvh_ltf[splitAxis]), splitValue));
+- u_int middle = distance(list.begin(), it);
++ u_int middle = std::distance(list.begin(), it);
+ middle = max(splits[j]+1, min(splits[j+1]-1, middle)); // Make sure coincidental BBs are still split
+ splits.insert(splits.begin()+j+1, middle);
+ }