summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-06-07 16:09:52 +0200
committerBenjamin Chrétien2014-06-07 16:09:55 +0200
commit9f7f8a5e1f8a0792c36a8dc1930f1fbe59997faa (patch)
treed565ea77615556226a70e1a029695f9ca532fc25
parent9a35aea6ea19e1e478d64579695ee3a820dd577b (diff)
downloadaur-9f7f8a5e1f8a0792c36a8dc1930f1fbe59997faa.tar.gz
indigo: use Python 2 rather than Python 3.
Since most packages are unlikely to be Python 3 ready before the next ROS distribution, we stick to Python 2.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c4c92796a6a..c015c3114640 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = ros-indigo-genlisp
pkgdesc = ROS - Common-Lisp ROS message and service generators.
pkgver = 0.4.13
- pkgrel = 1
+ pkgrel = 2
url = http://www.ros.org/wiki/roslisp
arch = any
license = BSD
makedepends = cmake
makedepends = git
makedepends = ros-build-tools
- makedepends = ros-indigo-catkin
makedepends = ros-indigo-genmsg
+ makedepends = ros-indigo-catkin
depends = ros-indigo-genmsg
source = genlisp::git+https://github.com/ros-gbp/genlisp-release.git#tag=release/indigo/genlisp/0.4.13-0
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c906b31405b7..d643d575dd0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,11 @@ pkgname='ros-indigo-genlisp'
pkgver='0.4.13'
_pkgver_patch=0
arch=('any')
-pkgrel=1
+pkgrel=2
license=('BSD')
-ros_makedepends=(ros-indigo-catkin
- ros-indigo-genmsg)
+ros_makedepends=(ros-indigo-genmsg
+ ros-indigo-catkin)
makedepends=('cmake' 'git' 'ros-build-tools'
${ros_makedepends[@]})
@@ -33,16 +33,16 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.4m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.4m.so \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}