summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSwyter2016-12-03 19:09:24 +0100
committerSwyter2016-12-03 19:09:24 +0100
commit9f87ef7819c9fe59edcf9390005edbb658e56921 (patch)
treeaa66384985e44d8325eb0f0e246f52dc683b1579
parent2dbc3969101ce0f19dd4e4718d5a0183af1c2a9c (diff)
downloadaur-9f87ef7819c9fe59edcf9390005edbb658e56921.tar.gz
VCG lib has migrated from Sourceforge/SVN to GitHub/Git, fix sources, build, and improve .pro file replacements and use the actual number of CPUs minus one. To make it fast while staying responsive.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d0fcaf6a488..7ca549c26f19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,13 +8,13 @@ pkgbase = openbrf
arch = x86_64
license = GPL
makedepends = icoutils
- makedepends = subversion
makedepends = git
+ makedepends = coreutils
depends = qt5-base
depends = glew
depends = glu
- source = git+https://github.com/cfcohen/openbrf.git
- source = svn://svn.code.sf.net/p/vcg/code/trunk/vcglib
+ source = git+https://github.com/cfcohen/openbrf
+ source = git+https://github.com/cnr-isti-vclab/vcglib
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 24fbc0604c54..1a1abcdb7b04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,9 +12,9 @@ arch=('i686' 'x86_64')
url="https://forums.taleworlds.com/index.php?topic=72279.0"
license=('GPL')
depends=('qt5-base' 'glew' 'glu')
-makedepends=('icoutils' 'subversion' 'git')
+makedepends=('icoutils' 'git' 'coreutils') # add coreutils for nproc
install=openbrf.install
-source=('git+https://github.com/cfcohen/openbrf.git' 'svn://svn.code.sf.net/p/vcg/code/trunk/vcglib')
+source=('git+https://github.com/cfcohen/openbrf' 'git+https://github.com/cnr-isti-vclab/vcglib')
md5sums=('SKIP' 'SKIP')
pkgver()
@@ -26,12 +26,16 @@ build()
{
cd "openbrf"
+ # extract all the Windows icon sub-images, we can later grab the 256px
+ # version and use it in Linux as XDG PNG icon.
icotool -x openBrf.ico
# use the correct location for our VCG lib, instead of the custom hardcoded path
- sed -e "s/VCGLIB = \/home\/cory\/Source\/VCGLib/VCGLIB = ..\/vcglib/" openBrf.pro --in-place
+ sed -e "s/VCGLIB = /VCGLIB = ..\/vcglib\/ #/" openBrf.pro --in-place
+
+ # build it as fast as possible, but leaving a free CPU core for other stuff!
qmake -makefile openBrf.pro
- make -j 4
+ make -j $[`nproc` - 1]
}
package()
@@ -75,6 +79,7 @@ EOF
<generic-icon name="openbrf"/>
<acronym>BRF</acronym>
<comment>Mount&amp;Blade Binary Resource File</comment>
+ <comment xml:lang="es">Recurso binario de Mount&amp;Blade</comment>
<glob pattern="*.brf"/>
</mime-type>
</mime-info>