summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenry-Joseph Audéoud2020-09-08 17:12:34 +0200
committerHenry-Joseph Audéoud2020-09-08 17:12:34 +0200
commit9f8fbb65b3ff1041b7d70f862d02e51fd6a6b617 (patch)
treeefde9390ba5127ca0b0ab1a067a903976e83087b
parent9ea04d534b0316c047c5bb2879f37330da28c570 (diff)
downloadaur-9f8fbb65b3ff1041b7d70f862d02e51fd6a6b617.tar.gz
upgpkg: ruby-certified 1.0.0-2
-rw-r--r--.SRCINFO4
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD15
3 files changed, 33 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d00c609df8f5..fe3d91a8fba2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,11 +5,13 @@ pkgbase = ruby-certified
url = http://github.com/stevegraham/certified
arch = any
license = MIT
- depends = ruby>=1.8.7
+ depends = ruby
noextract = certified-1.0.0.gem
options = !emptydirs
source = https://rubygems.org/downloads/certified-1.0.0.gem
+ source = https://raw.githubusercontent.com/stevegraham/certified/master/LICENSE
sha256sums = aa4cdf0e90e7ee96f6e0ce3daae39eaa8f0486124e0d92daf64d2105aeb9069c
+ sha256sums = cb9124a6b92829d36efa414520772710cb598096851cdc8b5b77f0da0b19f27a
pkgname = ruby-certified
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..81d86152ccb9
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2014 Stevie Graham
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 50a915534817..e850c7c723b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,15 +9,18 @@ pkgdesc="Ensure net/https verifies SSL certificates and provides certificate bun
arch=(any)
url="http://github.com/stevegraham/${_name}"
license=('MIT')
-depends=('ruby>=1.8.7')
+depends=('ruby')
options=(!emptydirs)
-source=("https://rubygems.org/downloads/${_name}-${pkgver}.gem")
+source=("https://rubygems.org/downloads/${_name}-${pkgver}.gem"
+ "https://raw.githubusercontent.com/stevegraham/certified/master/LICENSE")
noextract=("${_name}-${pkgver}.gem")
-sha256sums=('aa4cdf0e90e7ee96f6e0ce3daae39eaa8f0486124e0d92daf64d2105aeb9069c')
+sha256sums=('aa4cdf0e90e7ee96f6e0ce3daae39eaa8f0486124e0d92daf64d2105aeb9069c'
+ 'cb9124a6b92829d36efa414520772710cb598096851cdc8b5b77f0da0b19f27a')
package() {
- local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- gem install --ignore-dependencies --no-user-install \
- -i "${pkgdir}/${_gemdir}" -n "${pkgdir}/usr/bin" "${_name}-${pkgver}.gem"
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install \
+ -i "${pkgdir}/${_gemdir}" -n "${pkgdir}/usr/bin" "${_name}-${pkgver}.gem"
}