summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-06-04 20:42:43 -0500
committerLuis Martinez2021-06-06 11:00:54 -0500
commit9fa232ab64dc069ac593fdc6ff52187646fad885 (patch)
tree57c7c5e107f6df922d1c4cb133c6e529745319f9
downloadaur-9fa232ab64dc069ac593fdc6ff52187646fad885.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
-rw-r--r--neovim-trouble-git.install5
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69b619e17924
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = neovim-trouble-git
+ pkgdesc = A pretty diagnostics list for Neovim powered by LSP
+ pkgver = r70.a7dca62
+ pkgrel = 1
+ url = https://github.com/folke/trouble.nvim
+ install = neovim-trouble-git.install
+ arch = any
+ groups = neovim-plugins
+ license = unknown
+ makedepends = git
+ depends = neovim-git
+ provides = neovim-trouble
+ conflicts = neovim-trouble
+ source = neovim-trouble-git::git+https://github.com/folke/trouble.nvim
+ sha256sums = SKIP
+
+pkgname = neovim-trouble-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..931162a52773
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+
+pkgname=neovim-trouble-git
+pkgver=r70.a7dca62
+pkgrel=1
+pkgdesc="A pretty diagnostics list for Neovim powered by LSP"
+arch=('any')
+url="https://github.com/folke/trouble.nvim"
+license=('unknown')
+groups=('neovim-plugins')
+depends=('neovim-git')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install="$pkgname.install"
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find lua plugin \
+ -type f -exec install -Dvm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/neovim-trouble-git.install b/neovim-trouble-git.install
new file mode 100644
index 000000000000..df3aa44f09cf
--- /dev/null
+++ b/neovim-trouble-git.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo ':: A working LSP client must be installed in order to use this plugin.'
+ echo ':: Please consult upstream documentation on how to set up neovim-trouble.'
+ echo ':: A copy has been installed to /usr/share/doc/neovim-trouble-git/README.md'
+}