summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCody P Schafer2017-04-21 00:40:03 -0400
committerCody P Schafer2017-04-21 00:46:57 -0400
commit9fdccc8cef7bd2aff1a271bc3944b16de2f88fc7 (patch)
treeb67ef111d6d53e7a8a54d43b9a6dbd090ff2f4cd
parent098e62e57018b859aa239fc81c9195fda944c119 (diff)
downloadaur-9fdccc8cef7bd2aff1a271bc3944b16de2f88fc7.tar.gz
use git
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 27 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 988d9d78e389..274ec1f5f32f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
-pkgbase = upslug2-openwrt
+pkgbase = upslug2-git
pkgdesc = A tool to flash your NSLU2 (Slug) from a computer on a local network. (With OpenWRT patches)
- pkgver = 41
- pkgrel = 5
+ pkgver = r30.6fde222
+ pkgrel = 1
url = http://www.nslu2-linux.org/wiki/Main/UpSlug2
arch = i686
arch = x86_64
- license = custom
- makedepends = subversion
+ license = MIT
+ makedepends = git
depends = gcc-libs
- source = upslug2::svn+http://svn.nslu2-linux.org/svnroot/upslug2/trunk#revision=41
+ provides = upslug2
+ conflicts = upslug2
+ source = upslug2::git+https://github.com/wspringer/upslug2.git
source = 100-libpcap_fix.patch
source = 110-wrt350nv2_support.patch
md5sums = SKIP
md5sums = d50d808f117361f18bbe0726a73b40e2
md5sums = 80e4028a3c79dd4ac5dde263015d6063
-pkgname = upslug2-openwrt
+pkgname = upslug2-git
diff --git a/PKGBUILD b/PKGBUILD
index 8004741808de..e42e5df11a29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,34 @@
# Maintainer: Vianney le Clément de Saint-Marcq <vleclement AT gmail · com>
# Contributor: Michael Klier <chi@chimeric.de>
# Contributor: Laszlo Papp <djszapi2 at gmail com>
-pkgname=upslug2-openwrt
-pkgver=41
-pkgrel=5
+_bpn=upslug2
+pkgname=$_bpn-git
+pkgrel=1
pkgdesc="A tool to flash your NSLU2 (Slug) from a computer on a local network. (With OpenWRT patches)"
url="http://www.nslu2-linux.org/wiki/Main/UpSlug2"
depends=('gcc-libs')
-makedepends=('subversion')
+makedepends=('git')
+provides=("$_bpn")
+conflicts=("$_bpn")
arch=('i686' 'x86_64')
-license=('custom')
-source=("upslug2::svn+http://svn.nslu2-linux.org/svnroot/upslug2/trunk#revision=$pkgver"
+license=('MIT')
+source=("upslug2::git+https://github.com/wspringer/upslug2.git"
"100-libpcap_fix.patch"
"110-wrt350nv2_support.patch")
md5sums=('SKIP'
'd50d808f117361f18bbe0726a73b40e2'
'80e4028a3c79dd4ac5dde263015d6063')
+# from https://wiki.archlinux.org/index.php/VCS_package_guidelines
+pkgver=r30.6fde222
+pkgver() {
+ cd "$srcdir/upslug2"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
prepare() {
cd "$srcdir/upslug2"
patch -p1 < "$srcdir/100-libpcap_fix.patch"