summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Beard2017-11-17 13:53:37 +0000
committerJohn Beard2017-11-17 14:16:34 +0000
commit9fdf90a558a2e9de54586563feb75de631f6940e (patch)
tree86270438cda6f5aac785be0528c46373d9fe10a0
downloadaur-9fdf90a558a2e9de54586563feb75de631f6940e.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31652b592745
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = firefox-extension-textern-native-git
+ pkgdesc = Native component of Textern Firefox extension
+ pkgver = 0.4.2bb962d
+ pkgrel = 1
+ url = https://github.com/jlebon/textern
+ arch = any
+ license = GPL
+ depends = python
+ depends = firefox
+ source = git+https://github.com/jlebon/textern
+ source = git+https://github.com/chrisjbillington/inotify_simple
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = firefox-extension-textern-native-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe3b2fa25d27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: John Beard <john dot j dot beard at gmail dot com>
+# Author: Jonathan Lebon
+
+pkgname=firefox-extension-textern-native-git
+pkgver=0.4.2bb962d
+pkgrel=1
+url="https://github.com/jlebon/textern"
+license=('GPL')
+pkgdesc='Native component of Textern Firefox extension'
+arch=('any')
+source=("git+https://github.com/jlebon/textern"
+ "git+https://github.com/chrisjbillington/inotify_simple")
+depends=('python' 'firefox')
+md5sums=('SKIP' 'SKIP')
+
+prepare() {
+ cd "$srcdir/textern"
+
+ git submodule init
+ git config submodule.native/inotify_simple.url "$srcdir/inotify_simple"
+ git submodule update
+
+ # fix lib64/lib issue
+ sed 's/lib64/lib/g' -i Makefile
+}
+
+package() {
+ cd "$srcdir/textern"
+
+ make LIBEXEC="$pkgdir/usr/lib" DESTDIR="$pkgdir" native-install
+
+ # correct the json file - refers to pkgbuild dir, should be installed dir
+ sed -i -e "s|$pkgdir||g" "$pkgdir/usr/lib/mozilla/native-messaging-hosts/textern.json"
+}
+