summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Sarawinski2024-02-13 15:48:23 +0100
committerTimo Sarawinski2024-02-13 15:48:23 +0100
commit9fe5072bfc4448f85aa21f578edb8b65c62984dc (patch)
tree622e6ed38be8431671cb0b855c5a3bcd09e9ff76
parent32baef4be1c6b9a48d5034a55bfac6e09a2a3aaa (diff)
downloadaur-9fe5072bfc4448f85aa21f578edb8b65c62984dc.tar.gz
added patch for mariadb 11
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--mariadb11.patch14
3 files changed, 27 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 582d0cd75569..7bd33a68274c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mysqltuner
pkgdesc = MySQLTuner - review configuration quickly and make adjustments to increase performance and stability
pkgver = 2.5.3
- pkgrel = 1
+ pkgrel = 2
url = http://www.mysqltuner.com
arch = any
license = GPL
@@ -9,6 +9,8 @@ pkgbase = mysqltuner
makedepends = discount
depends = perl
source = mysqltuner::git+https://github.com/rackerhacker/MySQLTuner-perl.git#tag=ac43eee9692c7f5ffcbdd975c2bd370fda5868f8
+ source = mariadb11.patch
sha256sums = SKIP
+ sha256sums = d49b85da2cb9931c16a589dd3ebdfa2cbf5ad6406186c51488404d21b23d6a2a
pkgname = mysqltuner
diff --git a/PKGBUILD b/PKGBUILD
index 6c93935c8478..4dca1c296316 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,22 @@
pkgname=mysqltuner
pkgver=2.5.3
_tag='ac43eee9692c7f5ffcbdd975c2bd370fda5868f8'
-pkgrel=1
+pkgrel=2
pkgdesc='MySQLTuner - review configuration quickly and make adjustments to increase performance and stability'
arch=('any')
url='http://www.mysqltuner.com'
license=('GPL')
makedepends=('git' 'discount')
depends=('perl')
-source=("mysqltuner::git+https://github.com/rackerhacker/MySQLTuner-perl.git#tag=${_tag}")
-sha256sums=('SKIP')
+source=("mysqltuner::git+https://github.com/rackerhacker/MySQLTuner-perl.git#tag=${_tag}"
+ "mariadb11.patch")
+sha256sums=('SKIP'
+ 'd49b85da2cb9931c16a589dd3ebdfa2cbf5ad6406186c51488404d21b23d6a2a')
+
+prepare() {
+ cd mysqltuner/
+ patch -i "${srcdir}"/mariadb11.patch
+}
build() {
cd mysqltuner/
diff --git a/mariadb11.patch b/mariadb11.patch
new file mode 100644
index 000000000000..05083365e19d
--- /dev/null
+++ b/mariadb11.patch
@@ -0,0 +1,14 @@
+--- mysqltuner.pl
++++ mysqltuner.pl
+@@ -2446,7 +2446,10 @@
+ or mysql_version_eq( 10, 8 )
+ or mysql_version_eq( 10, 9 )
+ or mysql_version_eq( 10, 10 )
+- or mysql_version_eq( 10, 11 ) )
++ or mysql_version_eq( 10, 11 )
++ or mysql_version_eq( 11,0 )
++ or mysql_version_eq( 11,1 )
++ or mysql_version_eq( 11,2 ) )
+ {
+ goodprint "Currently running supported MySQL version "
+ . $myvar{'version'} . "";