summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrzej Giniewicz2015-07-07 21:35:14 +0200
committerAndrzej Giniewicz2015-07-07 21:35:14 +0200
commit9ff0fc875a0577bbd2b7a8d67f00799bdfed408c (patch)
tree598beda0ce4850032bf18d305d944082d5b8b692
downloadaur-9ff0fc875a0577bbd2b7a8d67f00799bdfed408c.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE.txt28
-rw-r--r--PKGBUILD32
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..daa1690eaeb2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python2-graphcanvas
+ pkgdesc = Interactive Graph (network) Visualization
+ pkgver = 4.0.2
+ pkgrel = 1
+ url = https://github.com/enthought/graphcanvas
+ arch = any
+ license = BSD
+ makedepends = python2-distribute
+ depends = python2-networkx
+ depends = python2-enable
+ conflicts = python2-graphcanvas-git
+ conflicts = python-ets-graphcanvas-svn
+ options = !emptydirs
+ source = https://github.com/enthought/graphcanvas/archive/4.0.2.tar.gz
+ source = LICENSE.txt
+ md5sums = f1652f04646b9210300244b4a70079b0
+ md5sums = ae6f5df0e6d4dd4ea3cc20aafb2dd10f
+
+pkgname = python2-graphcanvas
+
diff --git a/LICENSE.txt b/LICENSE.txt
new file mode 100644
index 000000000000..64ef4eeea682
--- /dev/null
+++ b/LICENSE.txt
@@ -0,0 +1,28 @@
+This software is OSI Certified Open Source Software.
+OSI Certified is a certification mark of the Open Source Initiative.
+
+Copyright (c) 2006, Enthought, Inc.
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+ * Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+ * Neither the name of Enthought, Inc. nor the names of its contributors may
+ be used to endorse or promote products derived from this software without
+ specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
+ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
+ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f0ced11f6a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
+pkgname=python2-graphcanvas
+pkgver=4.0.2
+pkgrel=1
+pkgdesc="Interactive Graph (network) Visualization"
+arch=('any')
+url="https://github.com/enthought/graphcanvas"
+license=('BSD')
+depends=('python2-networkx' 'python2-enable')
+makedepends=('python2-distribute')
+conflicts=('python2-graphcanvas-git' 'python-ets-graphcanvas-svn')
+options=(!emptydirs)
+
+source=("https://github.com/enthought/graphcanvas/archive/${pkgver}.tar.gz"
+ "LICENSE.txt")
+md5sums=('f1652f04646b9210300244b4a70079b0'
+ 'ae6f5df0e6d4dd4ea3cc20aafb2dd10f')
+
+build() {
+ cd "$srcdir"/graphcanvas-$pkgver
+
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir"/graphcanvas-$pkgver
+
+ python2 setup.py install --root="$pkgdir"/ --optimize=1
+
+ install -D "$srcdir/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+