summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Legner2020-05-15 10:30:09 +0200
committerSimon Legner2020-05-15 10:30:09 +0200
commita00e0c38efe9960567e93527486e84b91f855280 (patch)
tree0d5b94ec5757d11da78f1362a6463ee37fdb1d09
downloadaur-a00e0c38efe9960567e93527486e84b91f855280.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78aa4ec75610
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cht.sh-git
+ pkgdesc = The only cheat sheet you need (command line client for cheat.sh)
+ pkgver = r586.c4c3a62
+ pkgrel = 1
+ url = https://github.com/chubin/cheat.sh
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = curl
+ depends = xsel
+ depends = rlwrap
+ source = cht.sh-git::git+https://github.com/chubin/cheat.sh
+ sha1sums = SKIP
+
+pkgname = cht.sh-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84299f1180a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Simon Legner <Simon.Legner@gmail.com
+pkgname=cht.sh-git
+pkgver=r586.c4c3a62
+pkgrel=1
+pkgdesc="The only cheat sheet you need (command line client for cheat.sh)"
+arch=('any')
+url='https://github.com/chubin/cheat.sh'
+license=('MIT')
+depends=('curl' 'xsel' 'rlwrap')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/chubin/cheat.sh")
+sha1sums=(SKIP)
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 "share/cht.sh.txt" "$pkgdir/usr/bin/cht.sh"
+ install -Dm644 "share/bash_completion.txt" "$pkgdir/usr/share/bash-completion/completions/cht.sh"
+ install -Dm644 "share/fish.txt" "$pkgdir/usr/share/fish/vendor_completions.d/cht.sh.fish"
+ install -Dm644 "share/zsh.txt" "$pkgdir/usr/share/zsh/site-functions/_cht.sh"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}