summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorloziniak2024-02-10 15:54:01 +0100
committerloziniak2024-02-10 15:54:01 +0100
commita01e8c78fb4a95d366f0f1e4d034df39609458c4 (patch)
tree0eb89cf1c3c0ca0f241799cf34e340b1a0aa2a6c
parent6b7ba8416c6d994f6d17c0b28ad2cf583c641177 (diff)
downloadaur-a01e8c78fb4a95d366f0f1e4d034df39609458c4.tar.gz
take filename from value
-rw-r--r--PKGBUILD5
-rwxr-xr-xupdate_helper.sh2
2 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 58699095f994..c7243e051bed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,8 +15,9 @@ optdepends=(
provides=(red)
conflicts=(red ed)
options=(!strip)
+_filename="red-08feb24-1c3cd7363"
source=(
- "https://static.red-lang.org/dl/auto/linux/red-08feb24-1c3cd7363"
+ "https://static.red-lang.org/dl/auto/linux/$_filename"
"https://raw.githubusercontent.com/red/red/master/BSL-License.txt"
"https://raw.githubusercontent.com/red/red/master/BSD-3-License.txt")
sha256sums=(
@@ -28,7 +29,7 @@ sha256sums=(
package() {
cd "$srcdir"
- install -Dm755 red-08feb24-1c3cd7363 "$pkgdir/usr/bin/red"
+ install -Dm755 "$_filename" "$pkgdir/usr/bin/red"
install -dm755 "${pkgdir}/usr/share/licenses/$pkgname"
install -Dm644 BSL-License.txt "$pkgdir/usr/share/licenses/$pkgname/BSL-License.txt"
diff --git a/update_helper.sh b/update_helper.sh
index 664d76bc7f3f..eb54ac6c157e 100755
--- a/update_helper.sh
+++ b/update_helper.sh
@@ -12,7 +12,7 @@ wget -q https://static.red-lang.org/download.html
_date=$( grep -P '/dl/auto/linux/red-\K([0-9]{2}[a-z]{3}[0-9]{2})' -o download.html )
_commit=$( grep -P '/dl/auto/linux/red-[0-9]{2}[a-z]{3}[0-9]{2}-\K([0-9a-f]*)' -o download.html )
_filename="red-$_date-$_commit"
-echo -e "____ filename:\t $_filename"
+echo -e "____ _filename:\t $_filename"
echo "downloading $_filename ..."
wget -q "https://static.red-lang.org/dl/auto/linux/$_filename"