summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Pointhuber2015-11-24 19:05:23 +0100
committerThomas Pointhuber2015-11-24 19:05:23 +0100
commita0272f8ab2d5db6e1c44bf85d9451ead7dc72321 (patch)
treee9ec9c6c9d503e51ae740d8009cb48d870724d8f
downloadaur-a0272f8ab2d5db6e1c44bf85d9451ead7dc72321.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD49
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72214cbf8d78
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = limboole
+ pkgdesc = A simple tool for checking satisfiability respectively tautology on arbitrary structural formulas.
+ pkgver = 1.1
+ pkgrel = 1
+ url = http://fmv.jku.at/limboole/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ source = http://fmv.jku.at/limboole/limboole1.1.tar.gz
+ source = http://fmv.jku.at/picosat/picosat-960.tar.gz
+ sha256sums = fbf54fdfa7b6bd11c8e8246ba4367ff50287b6db264b0b3b39796c7c71855fe4
+ sha256sums = edb3184a04766933b092713d0ae5782e4a3da31498629f8bb2b31234a563e817
+
+pkgname = limboole
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da9aece56824
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Thomas Pointhuber <thomas.pointhuber@gmx.at>
+pkgname=limboole
+pkgver=1.1
+pkgrel=1
+pkgdesc="A simple tool for checking satisfiability respectively tautology on arbitrary structural formulas."
+arch=('i686' 'x86_64')
+url="http://fmv.jku.at/limboole/"
+license=('MIT') # binary falls under the license from picosat
+groups=()
+depends=()
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("http://fmv.jku.at/limboole/$pkgname$pkgver.tar.gz"
+ "http://fmv.jku.at/picosat/picosat-960.tar.gz")
+noextract=()
+sha256sums=('fbf54fdfa7b6bd11c8e8246ba4367ff50287b6db264b0b3b39796c7c71855fe4'
+ 'edb3184a04766933b092713d0ae5782e4a3da31498629f8bb2b31234a563e817')
+
+build() {
+ # build picosat for static binding
+ rm -rf "picosat"
+ mv "picosat-960" "picosat"
+ cd "picosat"
+ ./configure
+ make
+
+ # build limboole
+ cd "../$pkgname$pkgver"
+ ./configure.sh
+ make
+}
+
+check() {
+ cd "$pkgname$pkgver"
+ ./testlimboole
+}
+
+package() {
+ cd "$pkgname$pkgver"
+ install -d "$pkgdir/usr/bin"
+ cp limboole "$pkgdir/usr/bin/limboole"
+}