summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2023-08-26 20:41:38 -0400
committeréclairevoyant2023-08-26 20:42:33 -0400
commita032915e8630a79fd15275dfe4f98cd43f9b05be (patch)
tree6d6dbc6a9864ab6490424868cd59638b18a630be
parentce1a6192862a507a58470f7466b8efea51d03b8f (diff)
downloadaur-a032915e8630a79fd15275dfe4f98cd43f9b05be.tar.gz
y-cruncher: install all binaries and auxiliary files (closes eclairevoyant/aur-packages#6)
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD34
-rw-r--r--y-cruncher.LICENSE17
4 files changed, 26 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12fb30d7d776..4ab9539644be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = y-cruncher
pkgdesc = The first scalable multi-threaded Pi-benchmark for multi-core systems
pkgver = 0.8.1.9317
- pkgrel = 1
+ pkgrel = 2
url = http://www.numberworld.org/y-cruncher
arch = x86_64
license = custom
@@ -11,8 +11,6 @@ pkgbase = y-cruncher
depends = tbb
options = !strip
source = http://www.numberworld.org/y-cruncher/y-cruncher%20v0.8.1.9317-dynamic.tar.xz
- source = y-cruncher.LICENSE
b2sums = 295ce29002eff758773b1d250eadd679f4a9b633a8f068fa66b0593a19a24f0ddcef4ca213333360838a72d5e7c07c3fe9f44ff5c601d414ca11ed8b44fabf51
- b2sums = 54566d34c40a1ce90c19df611838a54c898f530b361c83998fc68103b108b5da4a03cd5616ffcdec5185c0fea2fc837ca2db337364d0d9c783ccbc746e9d92fc
pkgname = y-cruncher
diff --git a/.gitignore b/.gitignore
index f84c32631603..713f6f80aff8 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,3 @@
!/.gitignore
!/.SRCINFO
!/PKGBUILD
-!/y-cruncher.LICENSE
diff --git a/PKGBUILD b/PKGBUILD
index c9a1de67cd87..7e16fd7bc9fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,24 +7,40 @@
pkgname=y-cruncher
pkgver=0.8.1.9317
-pkgrel=1
+pkgrel=2
pkgdesc="The first scalable multi-threaded Pi-benchmark for multi-core systems"
arch=(x86_64)
url="http://www.numberworld.org/$pkgname"
license=(custom)
options=('!strip')
depends=(gcc-libs glibc numactl tbb)
-source=("$url/$pkgname%20v$pkgver-dynamic.tar.xz"
- "$pkgname.LICENSE"
-)
-b2sums=('295ce29002eff758773b1d250eadd679f4a9b633a8f068fa66b0593a19a24f0ddcef4ca213333360838a72d5e7c07c3fe9f44ff5c601d414ca11ed8b44fabf51'
- '54566d34c40a1ce90c19df611838a54c898f530b361c83998fc68103b108b5da4a03cd5616ffcdec5185c0fea2fc837ca2db337364d0d9c783ccbc746e9d92fc')
+source=("$url/$pkgname%20v$pkgver-dynamic.tar.xz")
+b2sums=('295ce29002eff758773b1d250eadd679f4a9b633a8f068fa66b0593a19a24f0ddcef4ca213333360838a72d5e7c07c3fe9f44ff5c601d414ca11ed8b44fabf51')
prepare() {
- mv "$pkgname v$pkgver-dynamic/Binaries/05-A64 ~ Kasumi" $pkgname
+ cd "$pkgname v$pkgver-dynamic"
+
+ sed '/Username: / s|Username.txt|/etc/xdg/y-cruncher-username.conf|' Username.txt > "$srcdir/$pkgname-username.txt"
+ rm Username.txt
+
+ mv "Binaries/Digits/Gamma(⅓).txt" "Binaries/Digits/Gamma(1-3).txt"
+ mv "Binaries/Digits/Gamma(¼).txt" "Binaries/Digits/Gamma(1-4).txt"
}
package() {
- install -vDm755 $pkgname -t "$pkgdir/usr/bin/"
- install -vDm644 $pkgname.LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$pkgname v$pkgver-dynamic"
+
+ install -vdm755 "$pkgdir/usr/lib/$pkgname/"
+ cp -rv --no-preserve=ownership $pkgname Binaries "Custom Formulas" -t "$pkgdir/usr/lib/$pkgname/"
+
+ # add wrapper binary to path
+ install -vdm755 "$pkgdir/usr/bin/"
+ ln -vs /usr/lib/$pkgname/$pkgname "$pkgdir/usr/bin/$pkgname"
+
+ # place conf file in XDG-compliant directory
+ install -vDm755 "$srcdir/$pkgname-username.txt" "$pkgdir/etc/xdg/y-cruncher-username.conf"
+ ln -vs /etc/xdg/y-cruncher-username.conf "$pkgdir/usr/lib/$pkgname/Username.txt"
+
+ install -vDm644 'Command Lines.txt' "$pkgdir/usr/share/doc/$pkgname/USAGE"
+ install -vDm644 'Read Me.txt' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/y-cruncher.LICENSE b/y-cruncher.LICENSE
deleted file mode 100644
index 2f5db764d692..000000000000
--- a/y-cruncher.LICENSE
+++ /dev/null
@@ -1,17 +0,0 @@
-Copyright 2008-2019 by Alexander J. Yee
-
-You may mirror and distribute this software free of charge for any purpose.
-You may use this software free of charge for any non-commercial purpose.
-You may also use this software for any academic purpose (including technology reviews), even if they are commercial.
-
-If wish to publicize a world record set using y-cruncher, you must indicate that it was done using this software.
-
-If you wish to use y-cruncher for commercial purposes, please contact the developer at: a-yee@u.northwestern.edu
-Commercial use licenses may be available depending on the intended usage.
-
-The terms of this license may change at any time with or without prior notification.
-The latest version of the license can be found at: www.numberworld.org/y-cruncher/license.html
-
-Disclaimers:
-
-This software is provided "as is" and the author disclaims all warranties with regard to this software including all implied warranties of merchantability and fitness. In no event shall the author be liable for any special, direct, indirect, or consequential damages, or any damages whatsoever resulting from loss of use, data or profits, whether in an action of contract, negligence or other tortious action, arising out of or in connection with the use or performance of this software.