summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiří Štefka2023-11-09 01:21:52 +0100
committerJiří Štefka2023-11-09 01:23:56 +0100
commita03cd849db98abf65890904a4336203b222fa90e (patch)
tree2889014643f9f3c9aadba477a33bfede3aaf9e7c
parent4fff525d441ee8a240045ce4c9e3eac6695b993f (diff)
downloadaur-a03cd849db98abf65890904a4336203b222fa90e.tar.gz
fix: use the new vulkan-utility-libraries
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7213b55b6ad2..4f37d3bb0dd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = vkdevicechooser
pkgdesc = Vulkan layer to force a specific physical GPU device to be used
- pkgver = 1.0
- pkgrel = 2
- url = https://github.com/aejsmith/vkdevicechooser
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/jiriks74/vkdevicechooser
arch = x86_64
license = MIT
makedepends = git
makedepends = vulkan-headers
- makedepends = vulkan-validation-layers
+ makedepends = vulkan-utility-libraries
makedepends = meson
makedepends = ninja
depends = vulkan-icd-loader
- source = https://github.com/aejsmith/vkdevicechooser/archive/refs/tags/1.0.zip
- md5sums = 5555405659067e6ba80fac37fcd556d4
+ conflicts = vkdevicechooser-git
+ source = https://github.com/jiriks74/vkdevicechooser/archive/refs/tags/1.1.zip
+ md5sums = b838ff799b1e729e11d1b950504672be
pkgname = vkdevicechooser
diff --git a/PKGBUILD b/PKGBUILD
index 256464eb4003..8ed5d3b1b4cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Maintainer: Entith <entith@entith.net>
-# Contributor: Vorpal <vorpal@riseup.net>
+# Maintainer: jiriks74 <jiri@stefka.eu>
+# Old maintainer: Entith <entith@entith.net>
pkgname=vkdevicechooser
-pkgver=1.0
-pkgrel=2
+pkgver=1.1
+pkgrel=1
pkgdesc="Vulkan layer to force a specific physical GPU device to be used"
arch=('x86_64')
-url="https://github.com/aejsmith/vkdevicechooser"
+url="https://github.com/jiriks74/vkdevicechooser"
license=('MIT')
depends=('vulkan-icd-loader')
-makedepends=('git' 'vulkan-headers' 'vulkan-validation-layers' 'meson' 'ninja')
-source=(https://github.com/aejsmith/vkdevicechooser/archive/refs/tags/1.0.zip)
-md5sums=('5555405659067e6ba80fac37fcd556d4')
+makedepends=('git' 'vulkan-headers' 'vulkan-utility-libraries' 'meson' 'ninja')
+conflicts=('vkdevicechooser-git')
+source=(https://github.com/jiriks74/vkdevicechooser/archive/refs/tags/1.1.zip)
+md5sums=('b838ff799b1e729e11d1b950504672be')
build() {
cd "${pkgname}-${pkgver}"