summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2015-07-28 19:45:27 -0400
committerTed Alff2015-07-28 19:45:27 -0400
commita046f687de20903124480f406b3a89c7b62f2f76 (patch)
tree7074d1b25ae6375d316a46920786cd1ee0ccdd8f
downloadaur-a046f687de20903124480f406b3a89c7b62f2f76.tar.gz
Initial AUR4 import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD45
-rw-r--r--icuinfo.makefile113
3 files changed, 176 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a882a9b41e23
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lib32-icu44
+ pkgdesc = International Components for Unicode library
+ pkgver = 4.4.2
+ pkgrel = 2
+ url = http://www.icu-project.org/
+ arch = x86_64
+ license = custom:"icu"
+ makedepends = gcc-multilib
+ depends = gcc-libs-multilib>=4.7.1-5
+ depends = sh
+ depends = icu44
+ source = http://download.icu-project.org/files/icu4c/4.4.2/icu4c-4_4_2-src.tgz
+ source = icuinfo.makefile
+ sha256sums = 2ecefdfb134b5b364ed01c2f613a9ccb11489dbae5857d63cd17ba5b6caca789
+ sha256sums = 213f0a174d24c5db46288514b9b15425f4a3cd9b7b254337d9fe140442139537
+
+pkgname = lib32-icu44
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..905c941a3a4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Art Gramlich <art@gramlich-net.com>
+# Maintainer: twa022 <twa022 at gmail dot com>
+
+_pkgname=icu
+pkgname=lib32-${_pkgname}44
+pkgver=4.4.2
+pkgrel=2
+pkgdesc="International Components for Unicode library"
+arch=(x86_64)
+url="http://www.icu-project.org/"
+license=('custom:"icu"')
+depends=('gcc-libs-multilib>=4.7.1-5' 'sh' "${_pkgname}44")
+makedepends=('gcc-multilib')
+source=(http://download.icu-project.org/files/${_pkgname}4c/${pkgver}/${_pkgname}4c-${pkgver//./_}-src.tgz
+ icuinfo.makefile)
+
+build() {
+ export CC='gcc -m32'
+ export CXX='g++ -m32 --std=c++0x'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ cd ${srcdir}/${_pkgname}/source
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --libdir=/usr/lib32
+
+ cp "${srcdir}"/icuinfo.makefile ./tools/icuinfo/Makefile
+ make
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}/source
+ make -j1 DESTDIR=${pkgdir} install
+ rm -r "${pkgdir}"/usr/{bin,include,sbin,share,lib32/*so,lib32/icu/{Makefile.inc,current,pkgdata.inc}}
+ chmod 755 "${pkgdir}"/usr/lib32/libicudata.so.44.2
+
+ # Install license
+ install -Dm644 ${srcdir}/${_pkgname}/license.html ${pkgdir}/usr/share/licenses/${pkgname}/license.html
+}
+
+sha256sums=('2ecefdfb134b5b364ed01c2f613a9ccb11489dbae5857d63cd17ba5b6caca789'
+ '213f0a174d24c5db46288514b9b15425f4a3cd9b7b254337d9fe140442139537')
diff --git a/icuinfo.makefile b/icuinfo.makefile
new file mode 100644
index 000000000000..847d660603ac
--- /dev/null
+++ b/icuinfo.makefile
@@ -0,0 +1,113 @@
+## Makefile.in for ICU - tools/icuinfo
+## Copyright (c) 1999-2010, International Business Machines Corporation and
+## others. All Rights Reserved.
+## Madhu Katragadda
+
+## Source directory information
+srcdir = .
+top_srcdir = ../..
+
+top_builddir = ../..
+
+include $(top_builddir)/icudefs.mk
+
+## Build directory information
+subdir = tools/icuinfo
+
+## Extra files to remove for 'make clean'
+CLEANFILES = *~ $(DEPS) $(PLUGIN_OBJECTS) $(PLUGINFILE) $(PLUGIN)
+
+## Target information
+TARGET = icuinfo$(EXEEXT)
+
+ifneq ($(top_builddir),$(top_srcdir))
+CPPFLAGS += -I$(top_builddir)/common
+endif
+CPPFLAGS += -I$(top_srcdir)/common -I$(srcdir)/../toolutil -I$(top_srcdir)/tools/ctestfw
+CPPFLAGS+= -I$(top_srcdir)/i18n
+LIBS = $(LIBCTESTFW) $(LIBICUTOOLUTIL) $(LIBICUI18N) $(LIBICUUC) $(DEFAULT_LIBS) $(LIB_M)
+
+OBJECTS = icuinfo.o
+PLUGIN_OBJECTS = testplug.o
+
+DEPS = $(OBJECTS:.o=.d)
+
+# pass some information
+
+ICUINFO_OPTS=-i ../../data/out/build/$(ICUDATA_PLATFORM_NAME)
+
+CPPFLAGS+= -DU_PLATFORM=\"U_LINUX\" -DU_BUILD=\"x86_64-unknown-linux-gnu\" -DU_HOST=\"x86_64-unknown-linux-gnu\"
+# -DENABLE_RELEASE=1 -DENABLE_DEBUG=0 "
+
+
+## List of phony targets
+.PHONY : all all-local install install-local clean clean-local \
+distclean distclean-local dist dist-local check check-local plugin-check
+
+## Clear suffix list
+.SUFFIXES :
+
+## List of standard targets
+all: all-local
+install: install-local
+clean: clean-local
+distclean : distclean-local
+dist: dist-local
+check: all check-local
+
+all-local: $(TARGET)
+
+install-local: all-local
+ $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
+ $(INSTALL) $(TARGET) $(DESTDIR)$(bindir)
+
+dist-local:
+
+clean-local:
+ test -z "$(CLEANFILES)" || $(RMV) $(CLEANFILES)
+ $(RMV) $(TARGET) $(OBJECTS)
+
+distclean-local: clean-local
+ $(RMV) Makefile
+
+check-local: $(TARGET)
+ $(INVOKE) ./$(TARGET) $(ICUINFO_OPTS)
+
+Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+-include Makefile.local
+
+$(TARGET) : $(OBJECTS)
+ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+ $(POST_BUILD_STEP)
+
+PLUGIN=$(LIBPREFIX)plugin.$(SO)
+SO_TARGET=$(PLUGIN)
+
+PLUGINDIR=$(shell pwd)
+
+PLUGINFILE=$(PLUGINDIR)/icuplugins$(SO_TARGET_VERSION_MAJOR).txt
+
+$(PLUGINFILE): Makefile
+ echo "$(CURR_FULL_DIR)/$(PLUGIN) myPlugin x=4" > $@
+
+CFLAGS+=$(SHAREDLIBCFLAGS)
+
+$(PLUGIN): $(PLUGIN_OBJECTS)
+ $(SHLIB.cc) $(SHAREDLIBCFLAGS) $(LD_SONAME) $(OUTOPT)$@ $^ $(LIBS)
+
+plugin: $(PLUGIN)
+
+plugin-check: $(PLUGIN) $(PLUGINFILE)
+ $(INVOKE) ICU_PLUGINS="$(CURR_FULL_DIR)" ./$(TARGET) -v -L
+
+
+ifeq (,$(MAKECMDGOALS))
+-include $(DEPS)
+else
+ifneq ($(patsubst %clean,,$(MAKECMDGOALS)),)
+-include $(DEPS)
+endif
+endif
+