summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-03-30 16:56:49 -0500
committerLuis Martinez2022-03-30 16:56:49 -0500
commita04781d7fb826abe7a02c80768b265a916787326 (patch)
tree47a3059cccc57d678c64af9972ecf49dd320b08d
parent7a5f4085ed96fcca9f01f1c34f486f5ca87191a6 (diff)
downloadaur-a04781d7fb826abe7a02c80768b265a916787326.tar.gz
package cleanup
-rw-r--r--.SRCINFO14
-rw-r--r--Makefile.patch41
-rw-r--r--PKGBUILD39
3 files changed, 70 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa0821e4ba01..30aca630c204 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = libcello
- pkgdesc = cello is a library that brings higher level programming to C
+ pkgdesc = Higher level programming library in C
pkgver = 2.1.0
- pkgrel = 1
- url = http://libcello.org/
- arch = i686
+ pkgrel = 2
+ url = https://github.com/orangeduck/cello
arch = x86_64
license = BSD
- makedepends = gcc
- source = https://github.com/orangeduck/Cello/archive/2.1.0.tar.gz
+ depends = glibc
+ source = libcello-2.1.0.tar.gz::https://github.com/orangeduck/cello/archive/2.1.0.tar.gz
+ source = Makefile.patch
sha256sums = c138d974325fcb9640307c8b2d5dcc2d7127a1ccc5589d6c0794f86a5cb4001d
+ sha256sums = a4930124b2b94ca3f7fffb3328d6b5521244e2b6a20bf418d2068a523c159d46
pkgname = libcello
-
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..98091fe6af64
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,41 @@
+diff --git a/Makefile b/Makefile
+index 31c9b99..d444c28 100644
+--- a/Makefile
++++ b/Makefile
+@@ -4,9 +4,9 @@ AR ?= ar
+ VERSION = 2.1.0
+ PACKAGE = libCello-$(VERSION)
+
+-BINDIR = ${PREFIX}/bin
+-INCDIR = ${PREFIX}/include
+-LIBDIR = ${PREFIX}/lib
++BINDIR = ${DESTDIR}/${PREFIX}/bin
++INCDIR = ${DESTDIR}/${PREFIX}/include
++LIBDIR = ${DESTDIR}/${PREFIX}/lib
+
+ SRC := $(wildcard src/*.c)
+ OBJ := $(addprefix obj/,$(notdir $(SRC:.c=.o)))
+@@ -18,7 +18,7 @@ EXAMPLES := $(wildcard examples/*.c)
+ EXAMPLES_OBJ := $(addprefix obj/,$(notdir $(EXAMPLES:.c=.o)))
+ EXAMPLES_EXE := $(EXAMPLES:.c=)
+
+-CFLAGS = -I ./include -std=gnu99 -Wall -Wno-unused -g -ggdb
++CFLAGS ?= -I ./include -std=gnu99 -Wall -Wno-unused -g -ggdb
+
+ PLATFORM := $(shell uname)
+ COMPILER := $(shell $(CC) -v 2>&1 )
+@@ -104,11 +104,9 @@ else
+ else
+ CFLAGS += -DCELLO_NSTRACE
+ endif
+-
+- INSTALL_LIB = mkdir -p ${LIBDIR} && cp -f ${STATIC} ${LIBDIR}/$(STATIC)
+- INSTALL_INC = mkdir -p ${INCDIR} && cp -r include/Cello.h ${INCDIR}
+- UNINSTALL_LIB = rm -f ${LIBDIR}/$(STATIC)
+- UNINSTALL_INC = rm -f ${INCDIR}/Cello.h
++
++ INSTALL_LIB = install -D ${DYNAMIC} -t ${LIBDIR}
++ INSTALL_INC = install -Dm644 include/Cello.h -t ${INCDIR}
+ endif
+
+ # Libraries
diff --git a/PKGBUILD b/PKGBUILD
index a524efd6a72f..74143d5d32d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,37 @@
-# Maintainer: Javier Tia <javier dot tia at gmail dot com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Javier Tia <javier dot tia at gmail dot com>
-_name=cello
-_Name=Cello
-pkgname=lib${_name}
+pkgname=libcello
pkgver=2.1.0
-pkgrel=1
-pkgdesc='cello is a library that brings higher level programming to C'
-arch=('i686' 'x86_64')
-url="http://libcello.org/"
+pkgrel=2
+pkgdesc='Higher level programming library in C'
+arch=('x86_64')
+url='https://github.com/orangeduck/cello'
license=('BSD')
-makedepends=('gcc')
-source=("https://github.com/orangeduck/${_Name}/archive/${pkgver}.tar.gz")
-sha256sums=('c138d974325fcb9640307c8b2d5dcc2d7127a1ccc5589d6c0794f86a5cb4001d')
+depends=('glibc')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+ 'Makefile.patch')
+sha256sums=('c138d974325fcb9640307c8b2d5dcc2d7127a1ccc5589d6c0794f86a5cb4001d'
+ 'a4930124b2b94ca3f7fffb3328d6b5521244e2b6a20bf418d2068a523c159d46')
+
+prepare() {
+ patch -p1 -d "Cello-$pkgver" < Makefile.patch
+}
build() {
- cd "${srcdir}/${_Name}-${pkgver}"
- make
+ cd "Cello-$pkgver"
+ make LFLAGS="${LDFLAGS}" CFLAGS+=-I./include
}
check() {
- cd "${srcdir}/${_Name}-${pkgver}"
+ cd "Cello-$pkgver"
make check
}
package() {
- cd "${srcdir}/${_Name}-${pkgver}"
- PREFIX="${pkgdir}/usr" make install
- install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "Cello-$pkgver"
+ make install PREFIX=/usr DESTDIR="$pkgdir/"
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim:set ft=sh ts=2 sw=2 et: