summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael F. Schönitzer2021-05-14 00:02:29 +0200
committerMichael F. Schönitzer2021-05-14 00:08:49 +0200
commita049e629232b6c34aac5323bb9d22da8fa76c847 (patch)
treef5d891c22ece1596520f952868de97892c0d84e2
parentdc2e9f8eeaf80e2f3af81764177f3ab209ade832 (diff)
downloadaur-a049e629232b6c34aac5323bb9d22da8fa76c847.tar.gz
Add function to generate version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6de2fba9f0a0..cb9919cdc225 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = getrid-git
pkgdesc = Terminal user interface to decide which packages to keep and which to get rid of
- pkgver = 0.2
- pkgrel = 2
+ pkgver = 0.2.1.r0.g13a0f7c
+ pkgrel = 1
url = https://github.com/Nudin/getrid
arch = any
license = GPL
depends = python
depends = python-urwid
depends = pacgraph
- source = $pkgname::git+https://github.com/Nudin/getrid.git
+ source = getrid-git::git+https://github.com/Nudin/getrid.git
md5sums = SKIP
pkgname = getrid-git
diff --git a/PKGBUILD b/PKGBUILD
index abd9152fc5da..263d287175d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,5 @@
# Maintainer: Michael Schönitzer <michael@schoenitzer.de>
pkgname=getrid-git
-pkgver=0.2
pkgrel=3
pkgdesc="Terminal user interface to decide which packages to keep and which to get rid of"
arch=('any')
@@ -10,6 +9,11 @@ depends=('python' 'python-urwid' 'pacgraph')
source=("$pkgname::git+https://github.com/Nudin/getrid.git")
md5sums=('SKIP')
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
package() {
cd "$pkgname"
make DESTDIR="$pkgdir/" install