summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Rueetschi2018-01-09 09:35:40 +0100
committerTobias Rueetschi2018-01-09 09:43:52 +0100
commita098dd885ae09268deeef1c30bdad4e79a6e48b4 (patch)
treef60925a7b54f9f1653f5bb834aaabe848f25d870
downloadaur-a098dd885ae09268deeef1c30bdad4e79a6e48b4.tar.gz
python leo version 1.0
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD37
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d843d4bf75f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-leo
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/keachi/python-leo
+ arch = any
+ license = Apache
+ makedepends = python
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = python-beautifulsoup4
+ depends = python-requests
+ depends = python-lxml
+ source = https://github.com/keachi/python-leo/archive/v1.0.tar.gz
+ sha256sums = 1b6e716f1c66ef4a9f083f1e7190d48d41a4edc4f985babb2babfeffea32eb18
+
+pkgname = python-leo
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..218620e2fb38
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/PKGBUILD
+!/.SRCINFO
+!/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42764f378eeb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# $Id$
+# Maintainer: Tobias Rueetschi <tr@brief.li>
+# Contributor: Tobias Rueetschi <tr@brief.li>
+
+pkgname='python-leo'
+pkgver=1.0
+pkgrel=1
+pkgdesc=''
+arch=('any')
+url='https://github.com/keachi/python-leo'
+license=('Apache')
+group=()
+depends=(
+ 'python'
+ 'python-beautifulsoup4'
+ 'python-requests'
+ 'python-lxml'
+)
+optdepends=()
+makedepends=(
+ 'python'
+ 'git'
+ 'python-setuptools'
+)
+checkdepends=()
+source=("https://github.com/keachi/python-leo/archive/v${pkgver}.tar.gz")
+sha256sums=('1b6e716f1c66ef4a9f083f1e7190d48d41a4edc4f985babb2babfeffea32eb18')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
+}