summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-04-25 02:42:44 +0800
committerUniversebenzene2020-04-25 02:42:44 +0800
commita10933d474433802cfe3acb64bf98b2704b66f36 (patch)
tree94de7798298fa5e22d89f72e8db5ccd4d868d521
parent809ed8764069c4770e8e8ec2179cfbd38b7bbefd (diff)
downloadaur-a10933d474433802cfe3acb64bf98b2704b66f36.tar.gz
Update to version 2.3.2
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD6
3 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e45e509a78b2..b86ff6b3be6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-sphinx-click
pkgdesc = Sphinx extension that automatically documents click applications
- pkgver = 2.3.1
+ pkgver = 2.3.2
pkgrel = 1
url = https://sphinx-click.readthedocs.io
arch = i686
@@ -13,9 +13,11 @@ pkgbase = python-sphinx-click
checkdepends = python2-click
makedepends = python-setuptools
makedepends = python2-setuptools
+ makedepends = python-pbr
+ makedepends = python2-pbr
makedepends = python-sphinx
- source = https://files.pythonhosted.org/packages/source/s/sphinx-click/sphinx-click-2.3.1.tar.gz
- md5sums = a3d1b7af95a2284d71bee6d9b513acf1
+ source = https://files.pythonhosted.org/packages/source/s/sphinx-click/sphinx-click-2.3.2.tar.gz
+ md5sums = 062fa89de7ced7d95c90508e8886288f
pkgname = python-sphinx-click
depends = python-sphinx>=1.5
diff --git a/.gitignore b/.gitignore
index 0d6e3b36c63a..e896dcd6056d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,5 +4,5 @@ pkg
*.tar.gz
*.tar.bz2
*.part
-*.pkg.tar.xz
+*.pkg.tar.*
*.log
diff --git a/PKGBUILD b/PKGBUILD
index fb63e29d60da..aee7e236f06c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
pkgbase=python-sphinx-click
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python2-${_pyname}" "python-${_pyname}-doc")
-pkgver=2.3.1
+pkgver=2.3.2
pkgrel=1
pkgdesc="Sphinx extension that automatically documents click applications"
arch=('i686' 'x86_64')
url="https://sphinx-click.readthedocs.io"
license=('MIT')
-makedepends=('python-setuptools' 'python2-setuptools' 'python-sphinx')
+makedepends=('python-setuptools' 'python2-setuptools' 'python-pbr' 'python2-pbr' 'python-sphinx')
#checkdepends=('python-coverage' 'python2-coverage' 'python2-sphinx' 'python-click' 'python2-click')
checkdepends=('python-pytest' 'python2-pytest' 'python2-sphinx' 'python-click' 'python2-click')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('a3d1b7af95a2284d71bee6d9b513acf1')
+md5sums=('062fa89de7ced7d95c90508e8886288f')
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}