summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2018-08-12 19:30:35 +0200
committerMuflone2018-08-12 19:30:35 +0200
commita10d4169a8f5ff51f4646dddde3593168aea90a5 (patch)
treea00ebdd8d80b9e08154a282c3780e579c879fc49
parenta06c84f230f4f0e320e435967ef13924d8032249 (diff)
downloadaur-a10d4169a8f5ff51f4646dddde3593168aea90a5.tar.gz
Updated package vmware-ovftool 4.3.0.7948156-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD44
2 files changed, 25 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d08302965f7a..5b3b3ed11d79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,19 @@
# Generated by mksrcinfo v8
-# Sun Nov 19 20:50:24 UTC 2017
+# Sun Aug 12 17:28:57 UTC 2018
pkgbase = vmware-ovftool
pkgdesc = VMware Open Virtualization Format tool
- pkgver = 4.2.0.4586971
- pkgrel = 2
+ pkgver = 4.3.0.7948156
+ pkgrel = 1
url = https://www.vmware.com/support/developer/ovf/
- arch = i686
arch = x86_64
license = custom:vmware
makedepends = xorg-server-xvfb
depends = curl
- depends = expat
- depends = libgpg-error
- depends = libpng12
depends = libxerces-c-3.1
- depends = zlib
- source_i686 = http://url.muflone.com/VMware-ovftool-4.2.0-4586971-lin.i386.bundle
- sha256sums_i686 = 53b894dfa977fbbdc7154b8e94e4746f7801e0a22b5881dd725b32638340bff6
- source_x86_64 = http://url.muflone.com/VMware-ovftool-4.2.0-4586971-lin.x86_64.bundle
- sha256sums_x86_64 = b1f84bfff40680c594da9840be0ffb4c36e377ae26abecddad12b4cadebfa8d8
+ depends = icu58
+ depends = icu60
+ source = http://url.muflone.com/VMware-ovftool-4.3.0-7948156-lin.x86_64.bundle
+ sha256sums = d327c8c7ebaac7432a589b1207410889d00c1ffd3fe18fa751b14459644de980
pkgname = vmware-ovftool
diff --git a/PKGBUILD b/PKGBUILD
index 58c303477c1a..c4cfaeafe290 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,40 @@
# Maintainer: Muflone http://www.muflone.com/contacts/english/
pkgname=vmware-ovftool
-pkgver=4.2.0.4586971
-pkgrel=2
+pkgver=4.3.0.7948156
+pkgrel=1
pkgdesc="VMware Open Virtualization Format tool"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://www.vmware.com/support/developer/ovf/"
license=('custom:vmware')
makedepends=('xorg-server-xvfb')
-depends=('curl' 'expat' 'libgpg-error' 'libpng12' 'libxerces-c-3.1' 'zlib')
-source_i686=("http://url.muflone.com/VMware-ovftool-${pkgver%.*}-${pkgver##*.}-lin.i386.bundle")
-source_x86_64=("http://url.muflone.com/VMware-ovftool-${pkgver%.*}-${pkgver##*.}-lin.x86_64.bundle")
-sha256sums_i686=('53b894dfa977fbbdc7154b8e94e4746f7801e0a22b5881dd725b32638340bff6')
-sha256sums_x86_64=('b1f84bfff40680c594da9840be0ffb4c36e377ae26abecddad12b4cadebfa8d8')
+depends=('curl' 'libxerces-c-3.1' 'icu58' 'icu60')
+source=("http://url.muflone.com/VMware-ovftool-${pkgver%.*}-${pkgver##*.}-lin.x86_64.bundle")
+sha256sums=('d327c8c7ebaac7432a589b1207410889d00c1ffd3fe18fa751b14459644de980')
prepare() {
# The bundle file doesn't allow extraction using symlinks or relative paths, here's then copied
- if [ "${CARCH}" = "x86_64" ]
- then
- _subarch="x86_64"
- else
- _subarch="i386"
- fi
- _bundlepath=$(readlink "${srcdir}/VMware-ovftool-${pkgver%.*}-${pkgver##*.}-lin.${_subarch}.bundle")
+ _bundlepath=$(readlink "${srcdir}/VMware-ovftool-${pkgver%.*}-${pkgver##*.}-lin.x86_64.bundle")
cp -f -L "${_bundlepath}" "${srcdir}/VMware-ovftool-${pkgver%.*}-${pkgver##*.}-${CARCH}_file.bundle"
}
build() {
- rm -rf "${srcdir}/build"
- xvfb-run -a sh "${srcdir}/VMware-ovftool-${pkgver%.*}-${pkgver##*.}-${CARCH}_file.bundle" -x "${srcdir}/build"
+ rm -rf "build"
+ xvfb-run -a sh "VMware-ovftool-${pkgver%.*}-${pkgver##*.}-${CARCH}_file.bundle" -x "${srcdir}/build"
# Remove duplicated system libraries
- cd "${srcdir}/build/${pkgname}"
- rm "libcurl.so.4" "libexpat.so" "libgcc_s.so.1" "libpng12.so.0" "libstdc++.so.6" \
- "libxerces-c-3.1.so" "libz.so.1"
+ cd "build/${pkgname}"
+ rm "libcares.so.2" "libcurl.so.4" "libexpat.so" "libgcc_s.so.1" "libstdc++.so.6" \
+ "libxerces-c-3.1.so" "libz.so.1" \
+ "icudt44l.dat" "libicudata.so.58" "libicuuc.so.58"
}
package() {
- cd "${srcdir}/build/${pkgname}"
+ cd "build/${pkgname}"
# Install binaries files
install -m 755 -d "${pkgdir}/usr/lib/${pkgname}"
- install -m 644 -t "${pkgdir}/usr/lib/${pkgname}" icudt44l.dat
- install -m 755 -t "${pkgdir}/usr/lib/${pkgname}" ovftool ovftool.bin lib*
+ install -m 755 -t "${pkgdir}/usr/lib/${pkgname}" "ovftool" "ovftool.bin" lib*
# Install data files
- for _subdir in certs env env/en schemas/DMTF schemas/vmware
+ for _subdir in "certs" "env" "env/en" "schemas/DMTF" "schemas/vmware"
do
install -m 755 -d "${pkgdir}/usr/lib/${pkgname}/${_subdir}"
install -m 644 -t "${pkgdir}/usr/lib/${pkgname}/${_subdir}" "${_subdir}"/*.*
@@ -53,9 +45,9 @@ package() {
# Install license files
install -m 755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
install -m 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" \
- vmware.eula vmware-eula.rtf open_source_licenses.txt
+ "vmware.eula" "vmware-eula.rtf" "open_source_licenses.txt"
# Install documentation files
install -m 755 -d "${pkgdir}/usr/share/doc/${pkgname}"
- install -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.txt
+ install -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}" "README.txt"
}