summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Lipp2015-06-15 20:17:22 +0200
committerMoritz Lipp2015-06-15 20:17:22 +0200
commita13c7eb2185dc04295e782fefb28a88f67df28a3 (patch)
tree3820a67c81259be3b93490ffa62480ca2835696c
downloadaur-a13c7eb2185dc04295e782fefb28a88f67df28a3.tar.gz
Initial import
-rw-r--r--.AURINFO18
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD44
3 files changed, 81 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..e213ce897564
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,18 @@
+pkgbase = lib32-libunwind-git
+ pkgdesc = Portable and efficient C programming interface (API) to determine the call-chain of a program
+ pkgver = 65ac867
+ pkgrel = 1
+ url = http://www.nongnu.org/libunwind/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = texlive-core
+ depends = glibc
+ depends = libunwind-git
+ provides = lib32-libunwind
+ conflicts = lib32-libunwind
+ source = lib32-libunwind-git::git+git://git.sv.gnu.org/libunwind.git
+
+pkgname = lib32-libunwind-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a73ca1c7200d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = lib32-libunwind-git
+ pkgdesc = Portable and efficient C programming interface (API) to determine the call-chain of a program
+ pkgver = 65ac867
+ pkgrel = 1
+ url = http://www.nongnu.org/libunwind/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = texlive-core
+ depends = glibc
+ depends = libunwind-git
+ provides = lib32-libunwind
+ conflicts = lib32-libunwind
+ source = lib32-libunwind-git::git+git://git.sv.gnu.org/libunwind.git
+ sha1sums = SKIP
+
+pkgname = lib32-libunwind-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42c14d87f007
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Moritz Lipp <mlq@pwmt.org>
+pkgname=lib32-libunwind-git
+pkgver=65ac867
+pkgrel=1
+pkgdesc="Portable and efficient C programming interface (API) to determine the call-chain of a program"
+arch=('i686' 'x86_64')
+url="http://www.nongnu.org/libunwind/"
+license=('GPL')
+makedepends=('git' 'texlive-core')
+depends=('glibc' 'libunwind-git')
+provides=('lib32-libunwind')
+conflicts=('lib32-libunwind')
+
+source=("${pkgname}::git+git://git.sv.gnu.org/libunwind.git")
+sha1sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ autoreconf -i
+ CFLAGS="-m32 -U_FORTIFY_SOURCE" LDFLAGS="-m32" ./configure --prefix=/usr \
+ --libdir=/usr/lib32 --target=i686-pc-linux-gnu
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname"
+ PATH=/usr/bin:$PATH make check || return 0
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+
+ find $pkgdir/usr/include/*.h -not -name "*x86*" -exec rm -f {} \;
+}
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ local ver="$(git describe --long --always)"
+ printf "%s" "${ver//-/.}"
+}
+
+# vim:set ts=2 sw=2 et: