summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsomini2021-07-20 02:46:23 +0100
committersomini2021-07-20 02:46:23 +0100
commita146c700dc505e04a8361fe781ad0c3732d59620 (patch)
tree78eca68949d4ef26b0b8d84a7876a9a32338d48e
parentb1d0ce092939f221fca155d80a07c9d72ded00d1 (diff)
downloadaur-a146c700dc505e04a8361fe781ad0c3732d59620.tar.gz
Calculate package version
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31c3d997c23c..6c1982e9c9d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bucklespring-libinput-git
pkgdesc = Nostalgia bucklespring keyboard sound, sampled from IBM's Model-M. libinput version
pkgver = latest
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/zevv/bucklespring
arch = i686
arch = x86_64
@@ -25,4 +25,3 @@ pkgbase = bucklespring-libinput-git
sha1sums = 26461f59226c610d54d3d6fb3824c537475cc8cd
pkgname = bucklespring-libinput-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 14b1c1f00430..db68d13d2275 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=bucklespring
pkgname=bucklespring-libinput-git
pkgver=latest
-pkgrel=5
+pkgrel=6
pkgdesc="Nostalgia bucklespring keyboard sound, sampled from IBM's Model-M. libinput version"
arch=('i686' 'x86_64')
url="https://github.com/zevv/bucklespring"
@@ -23,6 +23,11 @@ sha1sums=('SKIP'
'04b8a433d9d93d7cdc63303b433978f16348a78e'
'26461f59226c610d54d3d6fb3824c537475cc8cd')
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
cd "$_pkgname"
make PATH_AUDIO=/usr/share/bucklespring libinput=1