summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel YC Lin2015-06-13 11:40:25 +0800
committerDaniel YC Lin2015-06-13 11:40:25 +0800
commita14f5e1f36eb0d3e830714abed5964f61bd04aa2 (patch)
tree802380ca3a6c3d644b8321b832792ab32be70047
downloadaur-a14f5e1f36eb0d3e830714abed5964f61bd04aa2.tar.gz
merge to aur4
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD25
-rwxr-xr-xvimdoc.install20
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7002e7903f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vim-voom
+ pkgdesc = VOoM - Vim two-pane outliner. Support mediawiki,rest,markdown,...
+ pkgver = 5.1
+ pkgrel = 1
+ url = http://www.vim.org/scripts/script.php?script_id=2657
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = CCPL
+ depends = vim-runtime
+ depends = python2
+ conflicts = vim-voof
+ replaces = vim-voof
+ source = vim-voom.zip::http://www.vim.org/scripts/download_script.php?src_id=22082
+ sha1sums = 676044c5ab32099961d8af4114616283a43dc4d7
+
+pkgname = vim-voom
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05e7a6298f95
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+## Ignore everything
+*.zip
+*.xz
+*.gz
+*.bz2
+*.7z
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b89a91d1928
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Daniel YC Lin <dlin <at> gmail.com>
+# Contributor: Tianjiao Yin <ytj000@gmail.com>
+# Contributor: Laszlo Papp <djszapi @ gmail at com>
+
+pkgname=vim-voom
+pkgver=5.1
+_scriptid=22082
+pkgrel=1
+pkgdesc="VOoM - Vim two-pane outliner. Support mediawiki,rest,markdown,..."
+arch=('any')
+url="http://www.vim.org/scripts/script.php?script_id=2657"
+license=('CCPL')
+depends=('vim-runtime' 'python2')
+groups=('vim-plugins')
+conflicts=('vim-voof')
+replaces=('vim-voof')
+install=vimdoc.install
+source=(${pkgname}.zip::http://www.vim.org/scripts/download_script.php?src_id=${_scriptid})
+
+package() {
+ install -d ${pkgdir}/usr/share/vim/vimfiles
+ #rm ${pkgname}.zip
+ cp -a VOoM-$pkgver/* ${pkgdir}/usr/share/vim/vimfiles
+}
+sha1sums=('676044c5ab32099961d8af4114616283a43dc4d7')
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100755
index 000000000000..6b2d64f62b12
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo -n "Updating vim help tags..."
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" \
+ > /dev/null 2>&1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install
+}
+
+op=$1
+shift
+
+$op $*