summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrédéric Mangano-Tarumi2020-05-30 13:58:42 -0400
committerFrédéric Mangano-Tarumi2020-05-30 14:00:13 -0400
commita15153f29de4013e2fd27bc7597c66e925bec102 (patch)
treeafb555ff44b9e667273607237e03beece04fb92c
parentb0e714267da4a1c889d2af098088de2e7ea7363a (diff)
downloadaur-a15153f29de4013e2fd27bc7597c66e925bec102.tar.gz
port the upstream changes for 4.2.3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a4067f3f83b..e0d943f23fc7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
# Generated by mksrcinfo v8
-# Sat May 30 13:07:52 UTC 2020
+# Sat May 30 18:00:10 UTC 2020
pkgbase = ffmpeg-mmal
pkgdesc = ffmpeg built with MMAL hardware acceleration support for Raspberry Pi
pkgver = 4.2.3
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://ffmpeg.org/
arch = armv6h
arch = armv7h
arch = aarch64
license = GPL3
+ makedepends = avisynthplus
makedepends = git
makedepends = ladspa
makedepends = nasm
@@ -63,6 +64,7 @@ pkgbase = ffmpeg-mmal
depends = v4l-utils
depends = xz
depends = zlib
+ optdepends = avisynthplus: AviSynthPlus support
optdepends = ladspa: LADSPA filters
provides = ffmpeg
provides = libavcodec.so
diff --git a/PKGBUILD b/PKGBUILD
index 8b177a077cbf..aba9eb9989dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@
pkgname=ffmpeg-mmal
pkgver=4.2.3
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc='ffmpeg built with MMAL hardware acceleration support for Raspberry Pi'
arch=('armv6h' 'armv7h' 'aarch64')
@@ -74,11 +74,15 @@ depends=(
zlib
)
makedepends=(
+ avisynthplus
git
ladspa
nasm
)
-optdepends=('ladspa: LADSPA filters')
+optdepends=(
+ 'avisynthplus: AviSynthPlus support'
+ 'ladspa: LADSPA filters'
+)
provides=(
ffmpeg
libavcodec.so
@@ -91,8 +95,11 @@ provides=(
libswscale.so
)
conflicts=('ffmpeg')
-source=(git+https://git.ffmpeg.org/ffmpeg.git#tag=d3b963cc41824a3c5b2758ac896fb23e20a87875
- vmaf-model-path.patch)
+_tag=d3b963cc41824a3c5b2758ac896fb23e20a87875
+source=(
+ git+https://git.ffmpeg.org/ffmpeg.git#tag=${_tag}
+ vmaf-model-path.patch
+)
sha256sums=(
SKIP
8dff51f84a5f7460f8893f0514812f5d2bd668c3276ef7ab7713c99b71d7bd8d
@@ -107,9 +114,9 @@ pkgver() {
prepare() {
cd ffmpeg
- # lavf/mp3dec: don't adjust start time; packets are not adjusted
- # https://crbug.com/1062037
- git cherry-pick -n 460132c9980f8a1f501a1f69477bca49e1641233
+ # backport avisynthplus support
+ git show 6d8cddd1c67758636843f6a08295b3896c2e9ef8 -- libavformat/avisynth.c | git apply -
+ git show 56f59246293de417d27ea7e27cb9a7727ee579fb -- libavformat/avisynth.c | git apply -
patch -Np1 -i "${srcdir}"/vmaf-model-path.patch
}