summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522023-05-04 14:48:08 +0200
committertytan6522023-05-04 14:48:08 +0200
commita15201dbb6ed210358181a184cea8278fdb3f4c6 (patch)
treeb8e8498bf76b9a1a0e67fc6ea9517348e7d6d3eb
parent23df252cf4369cc7a01c7b71947e5d068918d625 (diff)
downloadaur-a15201dbb6ed210358181a184cea8278fdb3f4c6.tar.gz
build: Add -Wno-error=deprecated-declarations
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4141a9937c19..c207bc141239 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-source-record
pkgdesc = Plugin for OBS Studio to add a filter that allows you to record a source
pkgver = 0.3.2
- pkgrel = 1
+ pkgrel = 2
url = https://obsproject.com/forum/resources/source-record.1285/
arch = x86_64
arch = aarch64
@@ -9,6 +9,7 @@ pkgbase = obs-source-record
makedepends = cmake
makedepends = git
depends = obs-studio>=29
+ options = debug
source = obs-source-record::git+https://github.com/exeldro/obs-source-record#commit=4e27c040031831f9e9959f4947a6904ebe0fa23a
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index da9b5933f025..432befca788e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,29 @@
pkgname=obs-source-record
pkgver=0.3.2
-pkgrel=1
+pkgrel=2
pkgdesc="Plugin for OBS Studio to add a filter that allows you to record a source"
arch=("x86_64" "aarch64")
url="https://obsproject.com/forum/resources/source-record.1285/"
license=("GPL2")
depends=("obs-studio>=29")
makedepends=("cmake" "git")
+options=("debug")
source=("$pkgname::git+https://github.com/exeldro/$pkgname#commit=4e27c040031831f9e9959f4947a6904ebe0fa23a")
sha256sums=("SKIP")
build() {
- cd "$pkgname"
- cmake -B build \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ cmake -B build -S "$pkgname" \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_INSTALL_LIBDIR=lib \
-DLINUX_PORTABLE=OFF \
- -DQT_VERSION=6
+ -DQT_VERSION=6 \
+ -DCMAKE_C_FLAGS="-Wno-error=deprecated-declarations"
- make -C build
+ cmake --build build
}
package() {
- cd "$pkgname"
- make -C build DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir" cmake --install build
}