summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Boman2023-03-04 13:26:31 +0100
committerMagnus Boman2023-03-04 13:26:31 +0100
commita15e10751fcbc7587501968319457ddd25bafad8 (patch)
tree0dfcd19d2a2709b2e18f95d1d3f659091a7ef851
parent730a7cf333d0b0385cd74dcf34f1eaaad80bec29 (diff)
downloadaur-a15e10751fcbc7587501968319457ddd25bafad8.tar.gz
upgpkg: yt-dlp-git 2023.03.03.r3.g4a6272c6d-1
Workaround broken pkgver() and restore now working test
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec2f7f71d3f3..d834f9ee62b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yt-dlp-git
pkgdesc = A youtube-dl fork with additional features and fixes (git)
- pkgver = 2022.08.19.r10.g07275b708
+ pkgver = 2023.03.03.r3.g4a6272c6d
pkgrel = 1
url = https://github.com/yt-dlp/yt-dlp
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 0819c53b7ca1..c5444ba9f748 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: katt <magunasu.b97@gmail.com>
pkgname=yt-dlp-git
-pkgver=2022.08.19.r10.g07275b708
+pkgver=2023.03.03.r3.g4a6272c6d
pkgrel=1
pkgdesc='A youtube-dl fork with additional features and fixes (git)'
arch=(any)
@@ -22,6 +22,11 @@ conflicts=("${pkgname%-git}")
source=(git+"${url}".git)
sha256sums=('SKIP')
+prepare() {
+ # Ugly workaround to fix pkgver() reporting nightly.r0(...)
+ git -C "${pkgname%-git}" tag -d nightly
+}
+
pkgver() {
git -C "${pkgname%-git}" describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
@@ -34,8 +39,7 @@ build() {
check() {
cd "${pkgname%-git}"
- # Skip test_escaping as it breaks with ffmpeg 5.1, see https://github.com/yt-dlp/yt-dlp/issues/4604
- pytest -v -m "not download" -k "not test_escaping"
+ pytest -v -m "not download"
}
package() {