summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxwell G2021-09-03 15:51:20 -0500
committerMaxwell G2021-09-03 15:51:20 -0500
commita1613529bb71b9f535a0ad97abb9f4f9569367e8 (patch)
tree8d2a0cc2bfab767365084968d4167063fa54c220
downloadaur-a1613529bb71b9f535a0ad97abb9f4f9569367e8.tar.gz
Initial Commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
-rwxr-xr-xupdate2
4 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9086a46efd22
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = ansible-collection-kewlfft-aur
+ pkgdesc = Ansible collection that contains an Ansible module to manage packages from the AUR
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://galaxy.ansible.com/kewlfft/{aur}
+ arch = any
+ license = GPL3
+ depends = ansible-core
+ source = https://github.com/kewlfft/ansible-aur/archive/v0.9.0/ansible-aur-0.9.0.tar.gz
+ sha256sums = 4e3f51e8e0367b20c68a46158e3563f5a04243e820c817c51791990445b0ff87
+
+pkgname = ansible-collection-kewlfft-aur
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..03bb857d64a2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.zst
+/pkg/
+/src/
+ansible-aur-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3bf37b9730e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Maxwell G <gotmax@e.email>
+_collection_namespace=kewlfft
+_collection_name=aur
+_repo_name=ansible-aur
+_github_url="https://github.com/${_collection_namespace}/${_repo_name}"
+
+pkgname="ansible-collection-${_collection_namespace}-${_collection_name}"
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="Ansible collection that contains an Ansible module to manage packages from the AUR"
+arch=("any")
+url="https://galaxy.ansible.com/${_collection_namespace}/{$_collection_name}"
+license=("GPL3")
+depends=("ansible-core")
+source=("${_github_url}/archive/v${pkgver}/${_repo_name}-${pkgver}.tar.gz")
+sha256sums=('4e3f51e8e0367b20c68a46158e3563f5a04243e820c817c51791990445b0ff87')
+
+build() {
+ cd "${_repo_name}-${pkgver}"
+ ansible-galaxy collection build
+}
+
+package() {
+ cd "${_repo_name}-${pkgver}"
+ ansible-galaxy collection install -n -p \
+ "${pkgdir}/usr/share/ansible/collections" \
+ "${_collection_namespace}-${_collection_name}-${pkgver}.tar.gz"
+}
diff --git a/update b/update
new file mode 100755
index 000000000000..e3ff371b37da
--- /dev/null
+++ b/update
@@ -0,0 +1,2 @@
+updpkgsums
+makepkg --printsrcinfo > .SRCINFO