summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Riha2023-05-26 12:40:23 +0200
committerJose Riha2023-05-26 12:40:23 +0200
commita1630764e8ac277d3b57851f05a5b537989ed568 (patch)
treee4dba8c5c122d1efa0fd16298426d03e3d84ff7d
parent01c8cfbf010c50eade5f96640a221709a4baac02 (diff)
downloadaur-a1630764e8ac277d3b57851f05a5b537989ed568.tar.gz
Update libav source (thanks @qubidt)
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6549bac32ffd..fdf5f3a9dc38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = untrunc-git
pkgdesc = restore a damaged (truncated) mp4, m4v, mov, 3gp video
- pkgver = r142.e02f40e
+ pkgver = r183.10fd251
pkgrel = 1
url = https://github.com/ponchio/untrunc
arch = x86_64
@@ -12,13 +12,12 @@ pkgbase = untrunc-git
depends = libvdpau
depends = zlib
depends = bzip2
- noextract = libav-12.3.tar.xz
+ noextract = libav-12.3.tar.gz
source = untrunc-git::git+https://github.com/ponchio/untrunc.git
source = framealloc.patch
- source = http://libav.org/releases/libav-12.3.tar.xz
+ source = libav-12.3.tar.gz::https://github.com/libav/libav/archive/refs/tags/v12.3.tar.gz
md5sums = SKIP
md5sums = 7f6cf1762cd93f4ce84cb218ab856ea3
- md5sums = 753ec26481b0582eb737383bd8a350a5
+ md5sums = 78f791a4f595a67abd3a7d0c976524c5
pkgname = untrunc-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 343826bf3e26..5f8857fc5896 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Jose Riha <jose1711 gmail com>
# Contributor: archdaemon
# Contributor: sekret
+# Contributor: qubidt
pkgname=untrunc-git
-pkgver=r142.e02f40e
+pkgver=r183.10fd251
pkgrel=1
libav_version=12.3
pkgdesc="restore a damaged (truncated) mp4, m4v, mov, 3gp video"
@@ -14,15 +15,15 @@ depends=('libvdpau' 'zlib' 'bzip2')
makedepends=('yasm' 'git' 'libx11')
source=("${pkgname}"::'git+https://github.com/ponchio/untrunc.git'
'framealloc.patch'
- "http://libav.org/releases/libav-${libav_version}.tar.xz")
+ "libav-${libav_version}.tar.gz::https://github.com/libav/libav/archive/refs/tags/v${libav_version}.tar.gz")
md5sums=('SKIP'
'7f6cf1762cd93f4ce84cb218ab856ea3'
- '753ec26481b0582eb737383bd8a350a5')
-noextract=("libav-${libav_version}.tar.xz")
+ '78f791a4f595a67abd3a7d0c976524c5')
+noextract=("libav-${libav_version}.tar.gz")
prepare() {
cd $srcdir/$pkgname
- tar xvJf ../libav-${libav_version}.tar.xz
+ tar xf ../libav-${libav_version}.tar.xz
}
build() {