summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYaohan Chen2022-05-28 14:33:35 -0400
committerYaohan Chen2022-05-28 14:33:35 -0400
commita1943f548818aa8c07073f43693e8876f0e3cbb1 (patch)
tree2176fe00990d68a22a335f0338535df5da3b5d3b
parent2a95caac36b4066bbeaeb8d21d1a75cef71401f8 (diff)
downloadaur-a1943f548818aa8c07073f43693e8876f0e3cbb1.tar.gz
Fix build
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--anura.install16
3 files changed, 5 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e71614c476a..e4905ebd83b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = anura-git
pkgdesc = A fully-featured game engine, the tech behind the spectacular Frogatto & Friends.
- pkgver = 0.0.3619.ge4a2f2e7
+ pkgver = 0.0.3849.gfc9853001
pkgrel = 1
url = https://github.com/anura-engine/anura
- install = anura.install
arch = i686
arch = x86_64
license = GPL
@@ -21,7 +20,7 @@ pkgbase = anura-git
depends = boost-libs
optdepends = frogatto-git: the default game module
optdepends = box2d: box2d physics
- source = git+https://github.com/anura-engine/anura.git#branch=trunk
+ source = git+https://github.com/anura-engine/anura.git#branch=buildsystem-upgrade
source = git+https://github.com/sweetkristas/imgui.git
source = anura.sh
md5sums = SKIP
@@ -29,4 +28,3 @@ pkgbase = anura-git
md5sums = 15f4c03c2404bcfd7618b8f9e0c850ba
pkgname = anura-git
-
diff --git a/PKGBUILD b/PKGBUILD
index b0f9ebb425a1..aa30c37f4ed0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Yaohan Chen <yaohan.chen@gmail.com>
pkgname=anura-git
-pkgver=0.0.3619.ge4a2f2e7
+pkgver=0.0.3849.gfc9853001
pkgrel=1
pkgdesc="A fully-featured game engine, the tech behind the spectacular Frogatto & Friends."
arch=(i686 x86_64)
@@ -10,13 +10,12 @@ depends=(libgl mesa glew cairo sdl2 sdl2_image sdl2_ttf sdl2_mixer libpng boost-
optdepends=('frogatto-git: the default game module'
'box2d: box2d physics')
makedepends=(git boost)
-source=('git+https://github.com/anura-engine/anura.git#branch=trunk'
+source=('git+https://github.com/anura-engine/anura.git#branch=buildsystem-upgrade'
'git+https://github.com/sweetkristas/imgui.git'
anura.sh)
md5sums=('SKIP'
'SKIP'
'15f4c03c2404bcfd7618b8f9e0c850ba')
-install=anura.install
_gitname=anura
@@ -43,7 +42,7 @@ build() {
cd $_gitname
# USE_CCACHE=no to honor makepkg's ccache setting.
- make USE_CCACHE=no anura
+ make -e USE_CCACHE=no CXXFLAGS='-Wno-error=return-type' anura
}
package() {
diff --git a/anura.install b/anura.install
deleted file mode 100644
index 2eace418cb93..000000000000
--- a/anura.install
+++ /dev/null
@@ -1,16 +0,0 @@
-post_install() {
- chgrp users /usr/share/anura-git/modules
- chmod g+w /usr/share/anura-git/modules
-
- cat <<EOF
-Note: By default, anura will try to launch the frogatto module, which
- can be installed through the frogatto-git package. Use the
- --module= option to switch module. Modules are installed in
- /usr/share/anura-git/modules. This directory is made user writeable
- to allow the in-game editor's "new module" command to work.
-EOF
-}
-
-post_upgrade() {
- post_install
-}