summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-08-29 16:56:15 +0800
committerUniversebenzene2019-08-29 16:56:15 +0800
commita19bc9c67e47442077832022b8aeae723a87fd2d (patch)
tree6e1dc023ee801df4ca6d2c4fb062ce4e51923a87
parentaf045e070660d278083b28aba8251643d4883dde (diff)
downloadaur-a19bc9c67e47442077832022b8aeae723a87fd2d.tar.gz
Fix file conflict with stsci.tools
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 379bba499fea..68a5642b05fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-stsci.imagestats
pkgdesc = STScI clipped image statistics with core functionality of IRAF's imstatistics
pkgver = 1.6.2
- pkgrel = 1
+ pkgrel = 2
url = https://stsciimagestats.readthedocs.io/
arch = i686
arch = x86_64
@@ -17,5 +17,6 @@ pkgbase = python-stsci.imagestats
pkgname = python-stsci.imagestats
depends = python>=3.5
depends = python-numpy>=1.13
+ depends = python-stsci.tools
optdepends = python-stsci.imagestats-doc: Documentation for STScI Imagestats
diff --git a/PKGBUILD b/PKGBUILD
index e989949f7079..cdee730aaf23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=python-stsci.imagestats
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
pkgver=1.6.2
-pkgrel=1
+pkgrel=2
pkgdesc="STScI clipped image statistics with core functionality of IRAF's imstatistics"
arch=('i686' 'x86_64')
url="https://stsciimagestats.readthedocs.io/"
@@ -13,13 +13,16 @@ source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname
'https://raw.githubusercontent.com/spacetelescope/stsci.imagestats/master/LICENSE.txt')
md5sums=('54fde240cb959755efee0b9f0c8e9450'
'ca8dea23b938590a38eb415a5e448511')
+_pyver=$(python -V | cut -c 8-10)
package_python-stsci.imagestats() {
- depends=('python>=3.5' 'python-numpy>=1.13')
+ depends=('python>=3.5' 'python-numpy>=1.13' 'python-stsci.tools')
optdepends=('python-stsci.imagestats-doc: Documentation for STScI Imagestats')
cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" "${srcdir}/LICENSE.txt"
install -D -m644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.rst
python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+ rm "${pkgdir}/usr/lib/python3.7/site-packages/stsci/__init__.py"
+ rm "${pkgdir}/usr/lib/python3.7/site-packages/stsci/__pycache__"/*
}