summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Bender2020-09-07 00:16:30 +0200
committerErik Bender2020-09-07 08:42:19 +0200
commita1addc7c01a45f0d8330fc4694a47ee385423062 (patch)
tree851d038b22a0fa30884433f40ee72807d5a27504
downloadaur-a1addc7c01a45f0d8330fc4694a47ee385423062.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD34
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..06353a93c608
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = git-credential-1password-git
+ pkgdesc = Git credential.helper using 1Password for storage
+ pkgver = autogenerated
+ pkgrel = 1
+ url = https://github.com/develerik/git-credential-1password
+ arch = x86_64
+ license = ISC
+ makedepends = git
+ makedepends = go>=1.15
+ makedepends = make
+ depends = git
+ depends = 1password-cli
+ provides = git-credential-1password
+ conflicts = git-credential-1password-dev-git
+ conflicts = git-credential-1password-bin
+ conflicts = git-credential-1password
+ source = git+https://github.com/develerik/git-credential-1password.git
+ md5sums = SKIP
+
+pkgname = git-credential-1password-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8ebfacab0c9f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99a8509e9d47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Erik Bender <erik.bender@develerik.dev>
+
+_pkgname=git-credential-1password
+_orga=develerik
+_gourl=github.com/$_orga/$_pkgname
+
+pkgname="${_pkgname}-git"
+pkgver=autogenerated
+pkgrel=1
+pkgdesc="Git credential.helper using 1Password for storage"
+arch=('x86_64')
+url="https://$_gourl"
+license=('ISC')
+makedepends=('git' 'go>=1.15' 'make')
+depends=('git' '1password-cli')
+provides=('git-credential-1password')
+conflicts=("$_pkgname-dev-git" "$_pkgname-bin" "$_pkgname")
+source=("git+https://$_gourl.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $srcdir/$_pkgname
+ VERSION=$pkgver make credential-helper
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}/bin
+ install -DT -m0755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+}