summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-03-20 16:46:35 -0300
committerDaniel Bermond2022-03-20 16:46:35 -0300
commita1b5465b7404705e9916d5b43bf109fd76e4455d (patch)
treee5086137031cfd7d754b3f12d69c99b91165bfc1
parentd5b8f19d7967807915fc4f832f93cdc06f822c39 (diff)
downloadaur-a1b5465b7404705e9916d5b43bf109fd76e4455d.tar.gz
Add fix for avisynthplus
-rw-r--r--.SRCINFO4
-rw-r--r--060-ffmpeg-fix-segfault-with-avisynthplus.patch11
-rw-r--r--PKGBUILD10
3 files changed, 20 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c483587917d..ce45a25919db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-git
pkgdesc = Complete solution to record, convert and stream audio and video (git version)
- pkgver = 5.1.r105881.g1bed27acef
+ pkgver = 5.1.r106355.ga24e6ca8bf
pkgrel = 1
url = https://www.ffmpeg.org/
arch = x86_64
@@ -83,7 +83,9 @@ pkgbase = ffmpeg-git
conflicts = ffmpeg
source = git+https://git.ffmpeg.org/ffmpeg.git
source = 010-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
+ source = 060-ffmpeg-fix-segfault-with-avisynthplus.patch
sha256sums = SKIP
sha256sums = 91973c465f01446a999f278f0c2a3763304994dba1ac35de0e4c72f12f39409e
+ sha256sums = 887c2e440b159b7c3575a12eb17e1297b76f9468b65b96ef2674b7bb36b12fcf
pkgname = ffmpeg-git
diff --git a/060-ffmpeg-fix-segfault-with-avisynthplus.patch b/060-ffmpeg-fix-segfault-with-avisynthplus.patch
new file mode 100644
index 000000000000..1a43237953e4
--- /dev/null
+++ b/060-ffmpeg-fix-segfault-with-avisynthplus.patch
@@ -0,0 +1,11 @@
+--- a/libavformat/avisynth.c
++++ b/libavformat/avisynth.c
+@@ -121,7 +121,7 @@ static av_cold void avisynth_atexit_handler(void);
+
+ static av_cold int avisynth_load_library(void)
+ {
+- avs_library.library = dlopen(AVISYNTH_LIB, RTLD_NOW | RTLD_LOCAL);
++ avs_library.library = dlopen(AVISYNTH_LIB, RTLD_NOW | RTLD_DEEPBIND);
+ if (!avs_library.library)
+ return AVERROR_UNKNOWN;
+
diff --git a/PKGBUILD b/PKGBUILD
index 3dcf0455ae45..26db44ac5827 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: DrZaius <lou at fakeoutdoorsman.com>
pkgname=ffmpeg-git
-pkgver=5.1.r105881.g1bed27acef
+pkgver=5.1.r106355.ga24e6ca8bf
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (git version)'
arch=('x86_64')
@@ -85,12 +85,15 @@ provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'ffmpeg')
conflicts=('ffmpeg')
source=('git+https://git.ffmpeg.org/ffmpeg.git'
- '010-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch')
+ '010-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch'
+ '060-ffmpeg-fix-segfault-with-avisynthplus.patch')
sha256sums=('SKIP'
- '91973c465f01446a999f278f0c2a3763304994dba1ac35de0e4c72f12f39409e')
+ '91973c465f01446a999f278f0c2a3763304994dba1ac35de0e4c72f12f39409e'
+ '887c2e440b159b7c3575a12eb17e1297b76f9468b65b96ef2674b7bb36b12fcf')
prepare() {
patch -d ffmpeg -Np1 -i "${srcdir}/010-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch"
+ patch -d ffmpeg -Np1 -i "${srcdir}/060-ffmpeg-fix-segfault-with-avisynthplus.patch"
}
pkgver() {
@@ -101,7 +104,6 @@ pkgver() {
build() {
cd ffmpeg
-
printf '%s\n' ' -> Running ffmpeg configure script...'
./configure \