summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2020-05-18 19:24:57 +0200
committerNicola Murino2020-05-18 19:24:57 +0200
commita1decd7eaed69aebc2e28d3deee8e3ace7414c1b (patch)
treef0f2a7f3c70ca484d5dd22610b6ae187fe485e8a
parent20b13b8b4b5d1f630c6391de72d7be2464fc478d (diff)
downloadaur-a1decd7eaed69aebc2e28d3deee8e3ace7414c1b.tar.gz
Update to 3.3
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
-rw-r--r--fix_return_size.patch50
3 files changed, 9 insertions, 69 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba0b8067e691..8e20fdce95c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Fri Aug 19 06:02:51 UTC 2016
pkgbase = mingw-w64-libffi
pkgdesc = Portable foreign function interface library (mingw-w64)
- pkgver = 3.2.1
- pkgrel = 2
+ pkgver = 3.3
+ pkgrel = 1
url = http://sourceware.org/libffi
arch = any
license = MIT
@@ -12,10 +10,8 @@ pkgbase = mingw-w64-libffi
options = staticlibs
options = !buildflags
options = !strip
- source = ftp://sourceware.org/pub/libffi/libffi-3.2.1.tar.gz
- source = fix_return_size.patch
- sha1sums = 280c265b789e041c02e5c97815793dfc283fb1e6
- sha1sums = 812beef0a2dc35a834acbeb2fb4bdc04d7abfda0
+ source = https://sourceware.org/pub/libffi/libffi-3.3.tar.gz
+ sha256sums = 72fba7922703ddfa7a028d513ac15a85c8d54c8d67f55fa5a4802885dc652056
pkgname = mingw-w64-libffi
diff --git a/PKGBUILD b/PKGBUILD
index b34b9a83ff54..e1e127170fc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
+# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-libffi
-pkgver=3.2.1
-pkgrel=2
+pkgver=3.3
+pkgrel=1
pkgdesc="Portable foreign function interface library (mingw-w64)"
arch=(any)
depends=(mingw-w64-crt)
@@ -8,18 +9,11 @@ makedepends=(mingw-w64-configure)
options=(staticlibs !buildflags !strip)
license=(MIT)
url="http://sourceware.org/libffi"
-source=("ftp://sourceware.org/pub/libffi/libffi-${pkgver}.tar.gz"
-"fix_return_size.patch")
-sha1sums=('280c265b789e041c02e5c97815793dfc283fb1e6'
- '812beef0a2dc35a834acbeb2fb4bdc04d7abfda0')
+source=(https://sourceware.org/pub/libffi/libffi-$pkgver.tar.gz)
+sha256sums=('72fba7922703ddfa7a028d513ac15a85c8d54c8d67f55fa5a4802885dc652056')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-prepare() {
- cd "${srcdir}/libffi-${pkgver}"
- patch -p2 -i ../fix_return_size.patch
-}
-
build() {
cd "${srcdir}/libffi-${pkgver}"
unset LDFLAGS
diff --git a/fix_return_size.patch b/fix_return_size.patch
deleted file mode 100644
index 37a51ba7a463..000000000000
--- a/fix_return_size.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- src/libffi-3.2.1/src/x86/ffi.c.orig 2016-07-20 21:24:49.000771900 +0100
-+++ src/libffi-3.2.1/src/x86/ffi.c 2016-07-20 21:25:09.918786700 +0100
-@@ -65,7 +65,8 @@
- if ((ecif->cif->flags == FFI_TYPE_STRUCT
- || ecif->cif->flags == FFI_TYPE_MS_STRUCT)
- #ifdef X86_WIN64
-- && ((ecif->cif->rtype->size & (1 | 2 | 4 | 8)) == 0)
-+ && (ecif->cif->rtype->size != 1 && ecif->cif->rtype->size != 2
-+ && ecif->cif->rtype->size != 4 && ecif->cif->rtype->size != 8)
- #endif
- )
- {
-@@ -108,7 +109,7 @@
- #ifdef X86_WIN64
- if (z > FFI_SIZEOF_ARG
- || ((*p_arg)->type == FFI_TYPE_STRUCT
-- && (z & (1 | 2 | 4 | 8)) == 0)
-+ && (z != 1 && z != 2 && z != 4 && z != 8))
- #if FFI_TYPE_DOUBLE != FFI_TYPE_LONGDOUBLE
- || ((*p_arg)->type == FFI_TYPE_LONGDOUBLE)
- #endif
-@@ -360,7 +361,8 @@
- #ifdef X86_WIN64
- if (rvalue == NULL
- && cif->flags == FFI_TYPE_STRUCT
-- && ((cif->rtype->size & (1 | 2 | 4 | 8)) == 0))
-+ && cif->rtype->size != 1 && cif->rtype->size != 2
-+ && cif->rtype->size != 4 && cif->rtype->size != 8)
- {
- ecif.rvalue = alloca((cif->rtype->size + 0xF) & ~0xF);
- }
-@@ -545,7 +547,8 @@
- if ((cif->flags == FFI_TYPE_STRUCT
- || cif->flags == FFI_TYPE_MS_STRUCT)
- #ifdef X86_WIN64
-- && ((cif->rtype->size & (1 | 2 | 4 | 8)) == 0)
-+ && ((cif->rtype->size != 1 && cif->rtype->size != 2
-+ && cif->rtype->size != 4 && cif->rtype->size != 8))
- #endif
- )
- {
-@@ -608,7 +611,7 @@
- #ifdef X86_WIN64
- if (z > FFI_SIZEOF_ARG
- || ((*p_arg)->type == FFI_TYPE_STRUCT
-- && (z & (1 | 2 | 4 | 8)) == 0)
-+ && (z != 1 && z != 2 && z != 4 && z != 8))
- #if FFI_TYPE_DOUBLE != FFI_TYPE_LONGDOUBLE
- || ((*p_arg)->type == FFI_TYPE_LONGDOUBLE)
- #endif