summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Farley2016-06-23 01:36:15 -0500
committerRyan Farley2016-06-23 01:36:15 -0500
commita1ee3b26d74925c5c117ad810962d0bce936c733 (patch)
tree96ca8d7bc8503d31a441a683f3174b1ab9f8d245
downloadaur-a1ee3b26d74925c5c117ad810962d0bce936c733.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..667a98adf223
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = moshy-git
+ pkgdesc = A simple Mosh wrapper with profile settings
+ pkgver = r8.df0b2bc
+ pkgrel = 1
+ url = https://github.com/kiniou/moshy
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python-docopt
+ provides = moshy
+ conflicts = moshy
+ source = git+https://github.com/kiniou/moshy.git
+ md5sums = SKIP
+
+pkgname = moshy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75c34d773569
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Ryan Farley <ryan.farleyl@gmx.com>
+pkgname=moshy-git # '-bzr', '-git', '-hg' or '-svn'
+pkgver=r8.df0b2bc
+pkgrel=1
+pkgdesc="A simple Mosh wrapper with profile settings"
+arch=('any')
+url="https://github.com/kiniou/moshy"
+license=('GPL')
+depends=('python-docopt')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/kiniou/moshy.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}