summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2016-01-26 19:20:02 +0300
committerAnton Leontiev2016-01-26 19:21:28 +0300
commita2017eae93cfc1a02dacd3a178577fc0d900f562 (patch)
treed1c523cd44a95ab78f9c93d570000f714c8afc78
parent9d618c1a5371b772a34af1da7255777278e8dbba (diff)
downloadaur-a2017eae93cfc1a02dacd3a178577fc0d900f562.tar.gz
Update to 2.6.0-2
* Add README * Compile with -O3 and -DLinux
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile3
-rw-r--r--PKGBUILD12
3 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90c7af350d7e..01791911db65 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Jan 26 08:34:25 UTC 2016
+# Tue Jan 26 16:20:56 UTC 2016
pkgbase = ramspeed
pkgdesc = Open source utility to measure cache and memory performance
pkgver = 2.6.0
- pkgrel = 1
+ pkgrel = 2
url = http://alasir.com/software/ramspeed/
arch = i686
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = ramspeed
source = http://sources.buildroot.net/ramspeed-2.6.0.tar.gz
source = Makefile
md5sums = 546394131a1467a8651e0b8a218970c0
- md5sums = 03ff681717c551b53a736e9e3c6ea786
+ md5sums = 33e5d312ebfe6bb7730ce9695659c560
pkgname = ramspeed
diff --git a/Makefile b/Makefile
index d418b19fa696..b63e564c52e6 100644
--- a/Makefile
+++ b/Makefile
@@ -10,6 +10,9 @@ else
SOURCES += fltmem.c intmem.c fltmark.c intmark.c
endif
+CPPFLAGS += -DLinux
+CFLAGS += -O3
+
ramspeed: $(SOURCES)
echo $(CARCH)
$(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) $^ -o $@
diff --git a/PKGBUILD b/PKGBUILD
index fe43ccfdd0f4..206074d02fa0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Anton Leontyev <scileont /at/ gmail.com>
pkgname=ramspeed
pkgver=2.6.0
-pkgrel=1
+pkgrel=2
pkgdesc='Open source utility to measure cache and memory performance'
arch=('i686' 'x86_64')
depends=('glibc')
@@ -11,10 +11,12 @@ url='http://alasir.com/software/ramspeed/'
# but it may not work.
source=(http://sources.buildroot.net/$pkgname-$pkgver.tar.gz Makefile)
md5sums=('546394131a1467a8651e0b8a218970c0'
- '03ff681717c551b53a736e9e3c6ea786')
+ '33e5d312ebfe6bb7730ce9695659c560')
prepare() {
cp Makefile $pkgname-$pkgver/
+ sed -i 's:see the manual for details:see /usr/share/doc/ramspeed/README:' \
+ $pkgname-$pkgver/ramspeed.c
}
build() {
@@ -24,6 +26,8 @@ build() {
}
package() {
- install -Dm755 $pkgname-$pkgver/ramspeed "$pkgdir"/usr/bin/ramspeed
- install -Dm644 $pkgname-$pkgver/LICENCE "$pkgdir"/usr/share/licenses/ramspeed/LICENSE
+ cd $pkgname-$pkgver
+ install -Dm755 ramspeed "$pkgdir"/usr/bin/ramspeed
+ install -Dm644 LICENCE "$pkgdir"/usr/share/licenses/ramspeed/LICENSE
+ install -Dm644 README "$pkgdir"/usr/share/doc/ramspeed/README
}