summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-29 11:31:07 +0200
committerChristian Hesse2015-06-29 11:31:07 +0200
commita214786d4b65b57d913d91f4e7ba5e4a45b16a65 (patch)
tree95ec1932653703643998cd4258842e4dfa9689a3
downloadaur-a214786d4b65b57d913d91f4e7ba5e4a45b16a65.tar.gz
initial import of gimp-lensfun 0.2.3-4
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b3f772924fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gimp-lensfun
+ pkgdesc = A Gimp plugin to correct lens distortion using the lensfun library and database.
+ pkgver = 0.2.3
+ pkgrel = 4
+ url = http://seebk.github.io/GIMP-Lensfun/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gimp
+ depends = lensfun
+ depends = exiv2
+ source = https://github.com/seebk/GIMP-Lensfun/releases/download/0.2.3/gimplensfun-0.2.3.tar.gz
+ sha256sums = 509cc8b7e3ed44232c7132409281acdbbfddf3e1cd76bbf0b1893751818a43d9
+
+pkgname = gimp-lensfun
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ffa76a1a687
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=gimp-lensfun
+pkgver=0.2.3
+pkgrel=4
+pkgdesc="A Gimp plugin to correct lens distortion using the lensfun library and database."
+arch=('i686' 'x86_64')
+url="http://seebk.github.io/GIMP-Lensfun/"
+license=('GPL')
+depends=('gimp' 'lensfun' 'exiv2')
+source=("https://github.com/seebk/GIMP-Lensfun/releases/download/${pkgver}/gimplensfun-${pkgver}.tar.gz")
+sha256sums=('509cc8b7e3ed44232c7132409281acdbbfddf3e1cd76bbf0b1893751818a43d9')
+
+build() {
+ cd ${srcdir}/gimplensfun-${pkgver}
+
+ sed -i '/CCI/s|^|//|' src/gimplensfun.cpp
+
+ make
+}
+
+package() {
+ cd ${srcdir}/gimplensfun-${pkgver}
+
+ install -D -m0755 gimp-lensfun ${pkgdir}/usr/lib/gimp/2.0/plug-ins/gimp-lensfun
+
+ install -D -m0644 CHANGES.txt ${pkgdir}/usr/share/doc/gimp-lensfun/CHANGES.txt
+ install -D -m0644 LICENSE.txt ${pkgdir}/usr/share/doc/gimp-lensfun/LICENSE.txt
+ install -D -m0644 README.txt ${pkgdir}/usr/share/doc/gimp-lensfun/README.txt
+}
+